blob: a8b0e4f9c8e40fca024a645db6b642db7bd123f3 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Library for rendering SVG files"
2HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/librsvg/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "LGPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://rsvg.h;beginline=3;endline=24;md5=20b4113c4909bbf0d67e006778302bc6"
8
9SECTION = "x11/utils"
10DEPENDS = "cairo gdk-pixbuf glib-2.0 libcroco libxml2 pango"
11BBCLASSEXTEND = "native"
12
13inherit autotools pkgconfig gnomebase gtk-doc pixbufcache
14
15SRC_URI += "file://gtk-option.patch"
16
17SRC_URI[archive.md5sum] = "fadebe2e799ab159169ee3198415ff85"
18SRC_URI[archive.sha256sum] = "965c807438ce90b204e930ff80c92eba1606a2f6fd5ccfd09335c99896dd3479"
19
20EXTRA_OECONF = "--disable-introspection --disable-vala"
21
22# The older ld (2.22) on the host (Centos 6.5) doesn't have the
23# -Bsymbolic-functions option, we can disable it for native.
24EXTRA_OECONF_append_class-native = " --enable-Bsymbolic=auto"
25
26PACKAGECONFIG ??= "gdkpixbuf"
27# The gdk-pixbuf loader
28PACKAGECONFIG[gdkpixbuf] = "--enable-pixbuf-loader,--disable-pixbuf-loader,gdk-pixbuf-native"
29# GTK+ test application (rsvg-view)
30PACKAGECONFIG[gtk] = "--with-gtk3,--without-gtk3,gtk+3"
31
32do_install_append() {
33 # Loadable modules don't need .a or .la on Linux
34 rm -f ${D}${libdir}/gdk-pixbuf-2.0/*/loaders/*.a ${D}${libdir}/gdk-pixbuf-2.0/*/loaders/*.la
35}
36
37PACKAGES =+ "librsvg-gtk rsvg"
38FILES_${PN} = "${libdir}/*.so.*"
39FILES_${PN}-dbg += "${libdir}/gdk-pixbuf-2.0/*/loaders/.debug"
40FILES_rsvg = "${bindir}/rsvg* \
41 ${datadir}/pixmaps/svg-viewer.svg \
42 ${datadir}/themes"
43FILES_librsvg-gtk = "${libdir}/gdk-pixbuf-2.0/*/*/*.so"
44
45PIXBUF_PACKAGES = "librsvg-gtk"
46
47PIXBUFCACHE_SYSROOT_DEPS_append_class-native = " harfbuzz-native:do_populate_sysroot_setscene pango-native:do_populate_sysroot_setscene icu-native:do_populate_sysroot_setscene"