blob: cbaf0543654783d52357dcbf22c8da5fc9eb4e3c [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Custom Matchbox session files"
2HOMEPAGE = "http://www.matchbox-project.org/"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://matchbox-session;endline=20;md5=180f1c169a15d059a56c30094f6fb5ea"
7
8SECTION = "x11"
9RCONFLICTS_${PN} = "matchbox-common"
10
11SRC_URI = "file://matchbox-session"
12S = "${WORKDIR}"
13
14PR = "r4"
15
16inherit update-alternatives
17
18ALTERNATIVE_${PN} = "x-session-manager"
19ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/matchbox-session"
20ALTERNATIVE_PRIORITY = "100"
21
22do_install() {
23 install -d ${D}/${bindir}
24 install -m 0755 ${S}/matchbox-session ${D}/${bindir}
25}