blob: 0d825c98186c925f25747050482ad53a183f8b68 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "OpenGL driver testing framework"
2LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4
5SRC_URI = "git://anongit.freedesktop.org/piglit \
6 file://0001-tests-Fix-missing-include-of-Xutil.h.patch"
7
8# From 2014/12/04
9SRCREV = "126c7d049b8f32e541625d5a35fbc5f5e4e7fbf8"
10# (when PV goes above 1.0 remove the trailing r)
11PV = "1.0+gitr${SRCPV}"
12
13S = "${WORKDIR}/git"
14
15DEPENDS = "virtual/libx11 libxrender waffle virtual/libgl libglu python-mako-native python-numpy-native"
16
17inherit cmake pythonnative distro_features_check
18# depends on virtual/libx11
19REQUIRED_DISTRO_FEATURES = "x11"
20
21PACKAGECONFIG ??= ""
22PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
23
24do_configure_prepend() {
25 if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
26 sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
27 sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
28 fi
29}
30
31FILES_${PN}-dbg += "${libdir}/piglit/*/.debug/"
32
33RDEPENDS_${PN} = "waffle python python-mako python-json python-subprocess \
34 python-argparse python-importlib python-unixadmin \
35 python-multiprocessing python-textutils python-netserver python-shell \
36 mesa-demos bash \
37 "
38
39INSANE_SKIP_${PN} += "dev-so"