blob: b8aa05a2db55f9518aa440adc54f7b8b2814ab57 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "cross-platform C library to defer selection of GL API and of window system"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4c5154407c2490750dd461c50ad94797 \
4 file://include/waffle/waffle.h;endline=24;md5=61dbf8697f61c78645e75a93c585b1bf"
5
6SRC_URI = "http://waffle-gl.org/files/release/${BPN}-${PV}/${BPN}-${PV}.tar.xz"
7SRC_URI[md5sum] = "c0d802bc3d0aba87c51e423a3a8bdd69"
8SRC_URI[sha256sum] = "cbab0e926515064e818bf089a5af04be33307e5f40d07659fb40d59b2bfe20aa"
9
10inherit cmake distro_features_check lib_package
11
12# This should be overridden per-machine to reflect the capabilities of the GL
13# stack.
14PACKAGECONFIG ??= "glx"
15
16# libx11 requires x11 in DISTRO_FEATURES.
17REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'glx', 'x11', '', d)}"
18
19# I say virtual/libgl, actually wants gl.pc
20PACKAGECONFIG[glx] = "-Dwaffle_has_glx=1,-Dwaffle_has_glx=0,virtual/libgl libx11"
21
22# I say virtual/libgl, actually wants wayland-egl.pc, egl.pc, and the wayland
23# DISTRO_FEATURE.
24PACKAGECONFIG[wayland] = "-Dwaffle_has_wayland=1,-Dwaffle_has_wayland=0,virtual/libgl wayland"
25
26# I say virtual/libgl, actually wants gbm.pc egl.pc
27PACKAGECONFIG[gbm] = "-Dwaffle_has_gbm=1,-Dwaffle_has_gbm=0,virtual/libgl udev"
28
29# I say virtual/libgl, actually wants egl.pc
30PACKAGECONFIG[x11-egl] = "-Dwaffle_has_x11_egl=1,-Dwaffle_has_x11_egl=0,virtual/libgl libxcb"
31
32FILES_${PN}-dev += "${datadir}/cmake/Modules/FindWaffle.cmake \
33 ${libdir}/cmake/Waffle/"