blob: 38b78bcd0202b40fea6799490e53ab3bfdc82a10 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Startup script for the Weston Wayland compositor"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
4
5SRC_URI = "file://init"
6
7S = "${WORKDIR}"
8
9do_install() {
10 install -d ${D}/${sysconfdir}/init.d
11 install -m755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/weston
12}
13
14inherit allarch update-rc.d
15
16RDEPENDS_${PN} = "weston kbd"
17
18INITSCRIPT_NAME = "weston"
19INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ."