blob: ae4afd3d89fc93f8a1438eb71c5acd437f4e483a [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.x"
2DESCRIPTION = "The LTTng UST 2.x package contains the userspace tracer library to trace userspace codes."
3HOMEPAGE = "http://lttng.org/ust"
4BUGTRACKER = "https://bugs.lttng.org/projects/lttng-ust"
5
6LICENSE = "LGPLv2.1+ & MIT & GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \
8 file://snprintf/snprintf.c;endline=32;md5=d3d544959d8a3782b2e07451be0a903c \
9 file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44"
10
11inherit autotools lib_package
12
13DEPENDS = "liburcu util-linux"
14RDEPENDS_${PN}-bin = "python-core"
15
16# For backwards compatibility after rename
17RPROVIDES_${PN} = "lttng2-ust"
18RREPLACES_${PN} = "lttng2-ust"
19RCONFLICTS_${PN} = "lttng2-ust"
20
21SRCREV = "c49ee9040ada6984c880756614e8a6f7fd645bd6"
22PE = "2"
23PV = "2.6.2+git${SRCPV}"
24
25SRC_URI = "git://git.lttng.org/lttng-ust.git;branch=stable-2.6 \
26 file://lttng-ust-doc-examples-disable.patch \
27 file://lttng-ust-Fix-live-timer-calculation-error.patch \
28 "
29
30S = "${WORKDIR}/git"
31
32do_configure_prepend () {
33 ( cd ${S}; ${S}/bootstrap )
34}