blob: fbe2f669e81915a4562260e10b663ebeddee705a [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Real-Time preemption testcases"
2HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
3SECTION = "tests"
4DEPENDS = "linux-libc-headers virtual/libc"
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
7 file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=e768b8da44555fe63f65e5c497844cb5 \
8 file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949"
9
10require rt-tests.inc
11inherit ptest
12
13SRC_URI += "file://run-ptest \
14 file://rt_bmark.py \
15 "
16# Do not install hwlatdetect
17EXTRA_OEMAKE += "PYLIB=''"
18
19do_install() {
20 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
21 INCLUDEDIR=${includedir}
22}
23
24do_install_ptest() {
25 cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
26}
27
28RDEPENDS_${PN}-ptest += " stress python python-subprocess python-multiprocessing python-datetime python-re python-lang"
29
30FILES_${PN} += "${prefix}/src/backfire"