blob: bcfc9e9afaa206b175445c4dc666f9fcfd954e18 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001DESCRIPTION = "The PCRE library is a set of functions that implement regular \
2expression pattern matching using the same syntax and semantics as Perl 5. PCRE \
3has its own native API, as well as a set of wrapper functions that correspond \
4to the POSIX regular expression API."
5SUMMARY = "Perl Compatible Regular Expressions"
6HOMEPAGE = "http://www.pcre.org"
7SECTION = "devel"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=7e4937814aee14758c1c95b59c80c44d"
10SRC_URI = "${SOURCEFORGE_MIRROR}/project/pcre/pcre/${PV}/pcre-${PV}.tar.bz2 \
11 file://pcre-cross.patch \
12 file://fix-pcre-name-collision.patch \
13 file://run-ptest \
14 file://Makefile \
15"
16
17SRC_URI[md5sum] = "ed91be292cb01d21bc7e526816c26981"
18SRC_URI[sha256sum] = "51679ea8006ce31379fb0860e46dd86665d864b5020fc9cd19e71260eef4789d"
19
20S = "${WORKDIR}/pcre-${PV}"
21
22PROVIDES += "pcre"
23DEPENDS += "bzip2 zlib"
24
25PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline,"
26
27BINCONFIG = "${bindir}/pcre-config"
28
29inherit autotools binconfig-disabled ptest
30
31EXTRA_OECONF = "\
32 --enable-newline-is-lf \
33 --enable-rebuild-chartables \
34 --enable-utf8 \
35 --with-link-size=2 \
36 --with-match-limit=10000000 \
37"
38
39# Set LINK_SIZE in BUILD_CFLAGS given that the autotools bbclass use it to
40# set CFLAGS_FOR_BUILD, required for the libpcre build.
41BUILD_CFLAGS =+ "-DLINK_SIZE=2 -I${B}"
42CFLAGS += "-D_REENTRANT"
43CXXFLAGS_append_powerpc = " -lstdc++"
44
45PACKAGES =+ "libpcrecpp libpcreposix pcregrep pcregrep-doc pcretest pcretest-doc"
46
47SUMMARY_libpcrecpp = "${SUMMARY} - C++ wrapper functions"
48SUMMARY_libpcreposix = "${SUMMARY} - C wrapper functions based on the POSIX regex API"
49SUMMARY_pcregrep = "grep utility that uses perl 5 compatible regexes"
50SUMMARY_pcregrep-doc = "grep utility that uses perl 5 compatible regexes - docs"
51SUMMARY_pcretest = "program for testing Perl-comatible regular expressions"
52SUMMARY_pcretest-doc = "program for testing Perl-comatible regular expressions - docs"
53
54FILES_libpcrecpp = "${libdir}/libpcrecpp.so.*"
55FILES_libpcreposix = "${libdir}/libpcreposix.so.*"
56FILES_pcregrep = "${bindir}/pcregrep"
57FILES_pcregrep-doc = "${mandir}/man1/pcregrep.1"
58FILES_pcretest = "${bindir}/pcretest"
59FILES_pcretest-doc = "${mandir}/man1/pcretest.1"
60
61BBCLASSEXTEND = "native nativesdk"
62
63do_install_ptest() {
64 t=${D}${PTEST_PATH}
65 cp ${WORKDIR}/Makefile $t
66 cp -r ${S}/testdata $t
67 for i in pcre_stringpiece_unittest pcregrep pcretest; \
68 do cp ${B}/.libs/$i $t; \
69 done
70 for i in RunTest RunGrepTest test-driver; \
71 do cp ${S}/$i $t; \
72 done
73}