blob: 646872cb961fa4bde53cd654b4fe2ac5f7ae398f [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "libusb-0.1 compatibility layer for libusb1"
2DESCRIPTION = "libusb-0.1 compatible layer for libusb1, a drop-in replacement \
3that aims to look, feel and behave exactly like libusb-0.1"
4HOMEPAGE = "http://www.libusb.org/"
5BUGTRACKER = "http://www.libusb.org/report"
6SECTION = "libs"
7
8LICENSE = "LGPLv2.1+"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=f2ac5f3ac4835e8f91324a26a590a423"
10DEPENDS = "libusb1"
11
12# Few packages are known not to work with libusb-compat (e.g. libmtp-1.0.0),
13# so here libusb-0.1 is removed completely instead of adding virtual/libusb0.
14# Besides, libusb-0.1 uses a per 1ms polling that hurts a lot to power
15# consumption.
16PROVIDES = "libusb virtual/libusb0"
17BBCLASSEXTEND = "native nativesdk"
18
19PE = "1"
20
21SRC_URI = "${SOURCEFORGE_MIRROR}/libusb/libusb-compat-${PV}.tar.bz2 \
22 file://0001-usb.h-Include-sys-types.h.patch \
23 "
24
25SRC_URI[md5sum] = "2780b6a758a1e2c2943bdbf7faf740e4"
26SRC_URI[sha256sum] = "404ef4b6b324be79ac1bfb3d839eac860fbc929e6acb1ef88793a6ea328bc55a"
27
28BINCONFIG = "${bindir}/libusb-config"
29
30inherit autotools pkgconfig binconfig-disabled lib_package
31
32EXTRA_OECONF = "--libdir=${base_libdir}"
33
34do_install_append() {
35 install -d ${D}${libdir}
36 if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
37 mv ${D}${base_libdir}/pkgconfig ${D}${libdir}
38 fi
39}