blob: c836ca4b8683db24994c029a273cfa20a048d166 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Collection of simple PIN or passphrase entry dialogs"
2DESCRIPTION = "\
3 Pinentry is a collection of simple PIN or passphrase entry dialogs which \
4 utilize the Assuan protocol as described by the aegypten project; see \
5 http://www.gnupg.org/aegypten/ for details."
6
7HOMEPAGE = "http://www.gnupg.org/related_software/pinentry/index.en.html"
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=cbbd794e2a0a289b9dfcc9f513d1996e"
10
11inherit autotools
12
13SRC_URI = "ftp://ftp.gnupg.org/gcrypt/${BPN}/${BPN}-${PV}.tar.bz2"
14
15SRC_URI[md5sum] = "f51d454f921111b5156a2291cbf70278"
16SRC_URI[sha256sum] = "fd8bc1592ceb22bb492b07cb29b1b140bb882c859e6503b974254c0a4b4134d1"
17
18EXTRA_OECONF = "--disable-rpath \
19 --disable-dependency-tracking \
20 "
21
22PACKAGECONFIG ??= "ncurses libcap"
23
24PACKAGECONFIG[ncurses] = "--enable-ncurses --with-ncurses-include-dir=${STAGING_INCDIR}, --disable-ncurses, ncurses"
25PACKAGECONFIG[libcap] = "--with-libcap, --without-libcap, libcap"
26PACKAGECONFIG[qt4] = "--enable-pinentry-qt4, --disable-pinentry-qt4, qt4-x11"
27PACKAGECONFIG[qt4_clipboard] = "--enable-pinentry-qt4-clipboard --enable-pinentry-qt4, --disable-pinentry-qt4-clipboard, qt4-x11"
28PACKAGECONFIG[gtk2] = "--enable-pinentry-gtk2, --disable-pinentry-gtk2, gtk+ glib-2.0"
29
30#To use libsecret, add meta-gnome
31PACKAGECONFIG[secret] = "--enable-libsecret, --disable-libsecret, libsecret"