blob: 72280ec30d116d2061c1d6349f0d25c3e81d8339 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Python library used to interact with Git repositories"
2DESCRIPTION = "GitPython provides object model read and write access to \
3a git repository. Access repository information conveniently, alter the \
4index directly, handle remotes, or go down to low-level object database \
5access with big-files support."
6HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
7SECTION = "devel/python"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
10
11PYPI_PACKAGE = "GitPython"
12
13inherit pypi setuptools3
14
Andrew Geisslerc182c622020-05-15 14:13:32 -050015SRC_URI[md5sum] = "2397bea2d7c36ef9f874ab6355abae59"
16SRC_URI[sha256sum] = "864a47472548f3ba716ca202e034c1900f197c0fb3a08f641c20c3cafd15ed94"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
18DEPENDS += " ${PYTHON_PN}-gitdb"
19
20RDEPENDS_${PN} += " \
21 ${PYTHON_PN}-datetime \
22 ${PYTHON_PN}-gitdb \
23 ${PYTHON_PN}-io \
24 ${PYTHON_PN}-logging \
25 ${PYTHON_PN}-math \
26 ${PYTHON_PN}-netclient \
27 ${PYTHON_PN}-stringold \
28 ${PYTHON_PN}-unittest \
29 ${PYTHON_PN}-unixadmin \
30 git \
31"
32
33BBCLASSEXTEND = "native nativesdk"