blob: 8add14246144102dd6077dec59a85c3e7c8b385c [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
8SUMMARY_${PN}-dev = "Development files for manipulating RPM packages"
9DESCRIPTION_${PN}-dev = "This package contains the RPM C library and header files. These \
10development files will simplify the process of writing programs that \
11manipulate RPM packages and databases. These files are intended to \
12simplify the process of creating graphical package managers or any \
13other tools that need an intimate knowledge of RPM packages in order \
14to function."
15
16SUMMARY_python3-rpm = "Python bindings for apps which will manupulate RPM packages"
17DESCRIPTION_python3-rpm = "The python3-rpm package contains a module that permits applications \
18written in the Python programming language to use the interface \
19supplied by the RPM Package Manager libraries."
20
21HOMEPAGE = "http://www.rpm.org"
22
23# libraries are also LGPL - how to express this?
24LICENSE = "GPL-2.0"
25LIC_FILES_CHKSUM = "file://COPYING;md5=c0bf017c0fd1920e6158a333acabfd4a"
26
Andrew Geissler4b740dc2020-05-05 08:54:39 -050027SRC_URI = "git://github.com/rpm-software-management/rpm;branch=rpm-4.15.x \
Brad Bishop19323692019-04-05 15:28:33 -040028 file://0001-Do-not-add-an-unsatisfiable-dependency-when-building.patch \
29 file://0001-Do-not-read-config-files-from-HOME.patch \
30 file://0001-When-cross-installing-execute-package-scriptlets-wit.patch \
31 file://0001-Do-not-reset-the-PATH-environment-variable-before-ru.patch \
32 file://0002-Add-support-for-prefixing-etc-from-RPM_ETCCONFIGDIR-.patch \
33 file://0001-Do-not-hardcode-lib-rpm-as-the-installation-path-for.patch \
34 file://0001-Fix-build-with-musl-C-library.patch \
35 file://0001-Add-a-color-setting-for-mips64_n32-binaries.patch \
36 file://0011-Do-not-require-that-ELF-binaries-are-executable-to-b.patch \
Brad Bishop19323692019-04-05 15:28:33 -040037 file://0001-perl-disable-auto-reqs.patch \
38 file://0001-rpm-rpmio.c-restrict-virtual-memory-usage-if-limit-s.patch \
39 file://0016-rpmscript.c-change-logging-level-around-scriptlets-t.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050040 file://0001-rpmplugins.c-call-dlerror-prior-to-dlsym.patch \
Andrew Geissler4b740dc2020-05-05 08:54:39 -050041 file://0001-rpmfc.c-do-not-run-file-classification-in-parallel.patch \
Andrew Geisslerc182c622020-05-15 14:13:32 -050042 file://0001-lib-transaction.c-fix-file-conflicts-for-MIPS64-N32.patch \
Brad Bishop19323692019-04-05 15:28:33 -040043 "
44
45PE = "1"
Andrew Geissler4b740dc2020-05-05 08:54:39 -050046SRCREV = "ab2179452c5be276a6b96c591afded485c7e58c3"
Brad Bishop19323692019-04-05 15:28:33 -040047
48S = "${WORKDIR}/git"
49
Andrew Geissler82c905d2020-04-13 13:39:40 -050050DEPENDS = "openssl libarchive db file popt xz bzip2 dbus elfutils python3"
Brad Bishop19323692019-04-05 15:28:33 -040051DEPENDS_append_class-native = " file-replacement-native bzip2-replacement-native"
52
53inherit autotools gettext pkgconfig python3native
54export PYTHON_ABI
55
56# OE-core patches autoreconf to additionally run gnu-configize, which fails with this recipe
57EXTRA_AUTORECONF_append = " --exclude=gnu-configize"
58
Andrew Geissler82c905d2020-04-13 13:39:40 -050059EXTRA_OECONF_append = " --without-lua --enable-python --with-crypto=openssl"
Andrew Geissler4b740dc2020-05-05 08:54:39 -050060EXTRA_OECONF_append_libc-musl = " --disable-nls --disable-openmp"
Brad Bishop19323692019-04-05 15:28:33 -040061
62# --sysconfdir prevents rpm from attempting to access machine-specific configuration in sysroot/etc; we need to have it in rootfs
63#
64# --localstatedir prevents rpm from writing its database to native sysroot when building images
65#
66# Disable dbus for native, so that rpm doesn't attempt to inhibit shutdown via session dbus even when plugins support is enabled.
67# Also disable plugins by default for native.
68EXTRA_OECONF_append_class-native = " --sysconfdir=/etc --localstatedir=/var --disable-plugins"
69EXTRA_OECONF_append_class-nativesdk = " --sysconfdir=/etc --localstatedir=/var --disable-plugins"
70
71BBCLASSEXTEND = "native nativesdk"
72
73PACKAGECONFIG ??= ""
74PACKAGECONFIG[imaevm] = "--with-imaevm,,ima-evm-utils"
75
76ASNEEDED = ""
77
78# Direct rpm-native to read configuration from our sysroot, not the one it was compiled in
79# libmagic also has sysroot path contamination, so override it
80
81WRAPPER_TOOLS = " \
82 ${bindir}/rpm \
83 ${bindir}/rpm2archive \
84 ${bindir}/rpm2cpio \
85 ${bindir}/rpmbuild \
86 ${bindir}/rpmdb \
87 ${bindir}/rpmgraph \
88 ${bindir}/rpmkeys \
89 ${bindir}/rpmsign \
90 ${bindir}/rpmspec \
91 ${libdir}/rpm/rpmdeps \
92"
93
94do_install_append_class-native() {
95 for tool in ${WRAPPER_TOOLS}; do
96 create_wrapper ${D}$tool \
97 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
98 RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE} \
99 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
100 RPM_NO_CHROOT_FOR_SCRIPTS=1
101 done
102}
103
104do_install_append_class-nativesdk() {
105 for tool in ${WRAPPER_TOOLS}; do
106 create_wrapper ${D}$tool \
107 RPM_CONFIGDIR='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir'), d.getVar('bindir'))}/rpm \
108 RPM_ETCCONFIGDIR='$'{RPM_ETCCONFIGDIR-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir'), d.getVar('bindir'))}/..} \
109 MAGIC='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir'), d.getVar('bindir'))}/misc/magic.mgc \
110 RPM_NO_CHROOT_FOR_SCRIPTS=1
111 done
112
113 rm -rf ${D}/var
114}
115
116# Rpm's make install creates var/tmp which clashes with base-files packaging
117do_install_append_class-target() {
118 rm -rf ${D}/var
119}
120
121do_install_append () {
122 sed -i -e 's:${HOSTTOOLS_DIR}/::g' \
123 ${D}/${libdir}/rpm/macros
124
125 sed -i -e 's|/usr/bin/python|${USRBINPATH}/env ${PYTHON_PN}|' \
Andrew Geissler4b740dc2020-05-05 08:54:39 -0500126 ${D}${libdir}/rpm/pythondistdeps.py
Brad Bishop19323692019-04-05 15:28:33 -0400127}
128
129FILES_${PN} += "${libdir}/rpm-plugins/*.so \
130 "
131
132FILES_${PN}-dev += "${libdir}/rpm-plugins/*.la \
133 "
134
135PACKAGES += "python3-rpm"
136PROVIDES += "python3-rpm"
137FILES_python3-rpm = "${PYTHON_SITEPACKAGES_DIR}/rpm/*"
138
139# rpm 5.x was packaging the rpm build tools separately
140RPROVIDES_${PN} += "rpm-build"
141
142RDEPENDS_${PN} = "bash perl python3-core"
143
144PACKAGE_PREPROCESS_FUNCS += "rpm_package_preprocess"
145
146# Do not specify a sysroot when compiling on a target.
147rpm_package_preprocess () {
148 sed -i -e 's:--sysroot[^ ]*::g' \
149 ${PKGD}/${libdir}/rpm/macros
150}