Brad Bishop | bec4ebc | 2022-08-03 09:55:16 -0400 | [diff] [blame] | 1 | require recipes-devtools/atp/atp-source_3.1.inc |
Brad Bishop | bec4ebc | 2022-08-03 09:55:16 -0400 | [diff] [blame] | 2 | |
| 3 | SUMMARY = "End-to-end tests evaluating ATP kernel modules service correctness" |
| 4 | SECTION = "kernel/userland" |
| 5 | |
| 6 | S = "${WORKDIR}/git" |
| 7 | SRC_URI = "${ATP_SRC}" |
| 8 | |
| 9 | EXTRA_OEMAKE += "-C linux/test" |
| 10 | |
| 11 | do_compile() { |
| 12 | oe_runmake |
| 13 | } |
| 14 | |
| 15 | do_install() { |
| 16 | oe_runmake DESTDIR=${D} PREFIX=${prefix} install |
| 17 | } |
| 18 | |
| 19 | DEPENDS = "atp-uapi cppunit" |
| 20 | RDEPENDS:${PN} = "atp-uapi" |