Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "XFS Filesystem Dump Utility" |
| 2 | DESCRIPTION = "The xfsdump package contains xfsdump, xfsrestore and a \ |
| 3 | number of other utilities for administering XFS filesystems.\ |
| 4 | xfsdump examines files in a filesystem, determines which \ |
| 5 | need to be backed up, and copies those files to a \ |
| 6 | specified disk, tape or other storage medium." |
| 7 | HOMEPAGE = "http://oss.sgi.com/projects/xfs" |
| 8 | SECTION = "base" |
| 9 | LICENSE = "GPLv2" |
| 10 | LIC_FILES_CHKSUM = "file://doc/COPYING;md5=15c832894d10ddd00dfcf57bee490ecc" |
| 11 | DEPENDS = "xfsprogs attr" |
| 12 | |
| 13 | SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsdump/${BP}.tar.xz \ |
| 14 | file://remove-install-as-user.patch \ |
Brad Bishop | 90ca747 | 2019-08-20 09:15:15 -0400 | [diff] [blame] | 15 | file://work-with-new-version-of-xfsprogs.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 16 | " |
| 17 | SRC_URI[md5sum] = "84d3bc287b4a2bb5d16b2320a47049a7" |
| 18 | SRC_URI[sha256sum] = "ed14e67ae5b273c2698e767b43a46f033d361e540fe13feaaf9b110ee0edc585" |
| 19 | |
| 20 | inherit autotools-brokensep |
| 21 | |
| 22 | PARALLEL_MAKE = "" |
| 23 | PACKAGECONFIG ??= "" |
| 24 | PACKAGECONFIG[gettext] = "--enable-gettext=yes,--enable-gettext=no,gettext" |
| 25 | |
| 26 | CFLAGS += "-D_FILE_OFFSET_BITS=64" |
| 27 | |
| 28 | EXTRA_OEMAKE += "'LIBTOOL=${HOST_SYS}-libtool' V=1" |
| 29 | |
| 30 | do_configure () { |
| 31 | export DEBUG="-DNDEBUG" |
| 32 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S} |
| 33 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S} |
| 34 | oe_runconf |
| 35 | } |
| 36 | |
| 37 | do_install () { |
| 38 | export DIST_ROOT=${D} |
| 39 | oe_runmake install |
| 40 | oe_runmake install-dev |
| 41 | } |