blob: 23fe2021bedbbb026b19eb1b4dde4ddec0e6d575 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Distributed block device driver for Linux"
2DESCRIPTION = "DRBD is a block device which is designed to build high \
3 availability clusters. This is done by mirroring a whole \
4 block device via (a dedicated) network. You could see \
5 it as a network raid-1."
6HOMEPAGE = "http://oss.linbit.com/drbd/"
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
9DEPENDS = "virtual/kernel"
10
11SRC_URI = "http://www.linbit.com/downloads/drbd/9.0/drbd-${PV}.tar.gz \
12 file://check_existence_of_modules_before_installing.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040013 "
Brad Bishop0f291cc2019-09-01 15:16:57 -040014SRC_URI[md5sum] = "bd1202eaaf81641752d0c9b003b10f6c"
15SRC_URI[sha256sum] = "5b3d2bcb99542940e40af903dea783cf04524e9f41cc530e210d2c15ef84fa58"
Brad Bishopc342db32019-05-15 21:57:59 -040016
17inherit module
18
19EXTRA_OEMAKE += "KDIR='${STAGING_KERNEL_DIR}'"
20
21do_install () {
22 oe_runmake install DESTDIR="${D}"
23}
Brad Bishopc1d34332019-09-09 14:56:00 -040024
25PNBLACKLIST[drbd] = "Kernel module Needs forward porting to kernel 5.2+"