blob: b294d77bad019a2ed2cf7565d0d40f4e1af2f797 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "USB hub per-port power control"
2HOMEPAGE = "https://github.com/mvp/uhubctl"
3BUGTRACKER = "https://github.com/mvp/uhubctl/issues"
4DEPENDS = "libusb1"
5
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
Brad Bishopc1d34332019-09-09 14:56:00 -04009SRCREV = "c9fa3c68a1b2c9790c731602b8bae2b513e80605"
Brad Bishop26bdd442019-08-16 17:08:17 -040010SRC_URI = "git://github.com/mvp/${BPN}"
11S = "${WORKDIR}/git"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012
13# uhubctl gets its program version from "git describe". As we use the source
14# archive do reduce download size replace the call with our hardcoded version.
15do_configure_append() {
16 sed -i "s/^\(GIT_VERSION :=\).*$/\1 ${PV}/g" ${S}/Makefile
17}
18
19do_install () {
20 oe_runmake install DESTDIR=${D}
21}