blob: 1a20beec71cedcf9216ef8dc42fcaff5041a285d [file] [log] [blame]
Stanley Chuc28310e2020-06-18 14:04:42 +08001SUMMARY = "Power Cycle by Hotswap Controller"
2DESCRIPTION = "Power Cycle by Hotswap Controller Daemon"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8
9DEPENDS += "systemd"
10RDEPENDS_${PN} += "bash"
11
12SRC_URI = " file://hotswap-power-cycle.service"
13
14do_install() {
15 install -d ${D}${systemd_system_unitdir}
16 install -m 0644 ${WORKDIR}/hotswap-power-cycle.service ${D}${systemd_system_unitdir}
17}
18
19SYSTEMD_PACKAGES = "${PN}"
20SYSTEMD_SERVICE_${PN} = "hotswap-power-cycle.service"
21