blob: f6898c0b776feecd6179e4f62d739b03302d0a2b [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Versatile implementation of the Network Time Protocol"
2DESCRIPTION = "Chrony can synchronize the system clock with NTP \
3servers, reference clocks (e.g. GPS receiver), and manual input using \
4wristwatch and keyboard. It can also operate as an NTPv4 (RFC 5905) \
5server and peer to provide a time service to other computers in the \
6network. \
7\
8It is designed to perform well in a wide range of conditions, \
9including intermittent network connections, heavily congested \
10networks, changing temperatures (ordinary computer clocks are \
11sensitive to temperature), and systems that do not run continuously, or \
12run on a virtual machine. \
13\
14Typical accuracy between two machines on a LAN is in tens, or a few \
15hundreds, of microseconds; over the Internet, accuracy is typically \
16within a few milliseconds. With a good hardware reference clock \
17sub-microsecond accuracy is possible. \
18\
19Two programs are included in chrony: chronyd is a daemon that can be \
20started at boot time and chronyc is a command-line interface program \
21which can be used to monitor chronyd's performance and to change \
22various operating parameters whilst it is running. \
23\
24This recipe produces two binary packages: 'chrony' which contains chronyd, \
25the configuration file and the init script, and 'chronyc' which contains \
26the client program only."
27
28HOMEPAGE = "https://chrony.tuxfamily.org/"
29SECTION = "net"
30LICENSE = "GPLv2"
31LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
32
33SRC_URI = "https://download.tuxfamily.org/chrony/chrony-${PV}.tar.gz \
34 file://chrony.conf \
35 file://chronyd \
36 file://arm_eabi.patch \
37"
38
39SRC_URI_append_libc-musl = " \
40 file://0001-Fix-compilation-with-musl.patch \
41"
42
43SRC_URI[md5sum] = "7170e750469c198fc6784047d6f71144"
44SRC_URI[sha256sum] = "af77e47c2610a7e55c8af5b89a8aeff52d9a867dd5983d848b52d374bc0e6b9f"
45
46DEPENDS = "pps-tools"
47
48# Note: Despite being built via './configure; make; make install',
49# chrony does not use GNU Autotools.
50inherit update-rc.d systemd
51
52# Configuration options:
53# - For command line editing support in chronyc, you may specify either
54# 'editline' or 'readline' but not both. editline is smaller, but
55# many systems already have readline for other purposes so you might want
56# to choose that instead. However, beware license incompatibility
57# since chrony is GPLv2 and readline versions after 6.0 are GPLv3+.
58# You can of course choose neither, but if you're that tight on space
59# consider dropping chronyc entirely (you can use it remotely with
60# appropriate chrony.conf options).
61# - Security-related:
62# - 'sechash' is omitted by default because it pulls in nss which is huge.
63# - 'privdrop' allows chronyd to run as non-root; would need changes to
64# chrony.conf and init script.
65# - 'scfilter' enables support for system call filtering, but requires the
66# kernel to have CONFIG_SECCOMP enabled.
67PACKAGECONFIG ??= "editline \
68 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
69"
70PACKAGECONFIG[readline] = "--without-editline,--without-readline,readline"
71PACKAGECONFIG[editline] = ",--without-editline,libedit"
72PACKAGECONFIG[sechash] = "--without-tomcrypt,--disable-sechash,nss"
73PACKAGECONFIG[privdrop] = ",--disable-privdrop,libcap"
74PACKAGECONFIG[scfilter] = "--enable-scfilter,--without-seccomp,libseccomp"
75PACKAGECONFIG[ipv6] = ",--disable-ipv6,"
76PACKAGECONFIG[nss] = "--with-nss,--without-nss,nss"
77PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
78
79# --disable-static isn't supported by chrony's configure script.
80DISABLE_STATIC = ""
81
82do_configure() {
83 ./configure --sysconfdir=${sysconfdir} --bindir=${bindir} --sbindir=${sbindir} \
84 --localstatedir=${localstatedir} --datarootdir=${datadir} \
85 ${PACKAGECONFIG_CONFARGS}
86}
87
88do_install() {
89 # Binaries
90 install -d ${D}${bindir}
91 install -m 0755 ${S}/chronyc ${D}${bindir}
92 install -d ${D}${sbindir}
93 install -m 0755 ${S}/chronyd ${D}${sbindir}
94
95 # Config file
96 install -d ${D}${sysconfdir}
97 install -m 644 ${WORKDIR}/chrony.conf ${D}${sysconfdir}
98
99 # System V init script
100 install -d ${D}${sysconfdir}/init.d
101 install -m 755 ${WORKDIR}/chronyd ${D}${sysconfdir}/init.d
102
103 # systemd unit configuration file
104 install -d ${D}${systemd_unitdir}/system
105 install -m 0644 ${S}/examples/chronyd.service ${D}${systemd_unitdir}/system/
106
107 # Variable data (for drift and/or rtc file)
108 install -d ${D}${localstatedir}/lib/chrony
109
110 # Log files
111 install -d ${D}${localstatedir}/log/chrony
112
113 # Fix hard-coded paths in config files and init scripts
114 sed -i -e 's!/var/!${localstatedir}/!g' -e 's!/etc/!${sysconfdir}/!g' \
115 -e 's!/usr/sbin/!${sbindir}/!g' -e 's!/usr/bin/!${bindir}/!g' \
116 ${D}${sysconfdir}/chrony.conf \
117 ${D}${sysconfdir}/init.d/chronyd \
118 ${D}${systemd_unitdir}/system/chronyd.service
119 sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${sysconfdir}/init.d/chronyd
120 sed -i 's!^EnvironmentFile=.*!EnvironmentFile=-${sysconfdir}/default/chronyd!' ${D}${systemd_unitdir}/system/chronyd.service
121}
122
123FILES_${PN} = "${sbindir}/chronyd ${sysconfdir} ${localstatedir}"
124CONFFILES_${PN} = "${sysconfdir}/chrony.conf"
125INITSCRIPT_NAME = "chronyd"
126INITSCRIPT_PARAMS = "defaults"
127SYSTEMD_PACKAGES = "${PN}"
128SYSTEMD_SERVICE_${PN} = "chronyd.service"
129
130# It's probably a bad idea to run chrony and another time daemon on
131# the same system. systemd includes the SNTP client 'timesyncd', which
132# will be disabled by chronyd.service, however it will remain on the rootfs
133# wasting 150 kB unless you put 'PACKAGECONFIG_remove_pn-systemd = "timesyncd"'
134# in a conf file or bbappend somewhere.
135RCONFLICTS_${PN} = "ntp ntimed"
136
137# Separate the client program into its own package
138PACKAGES =+ "chronyc"
139FILES_chronyc = "${bindir}/chronyc"