blob: a03b92f5fe0144716aaf53808174271a450b1b14 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001# Copyright (C) 2016 Joe MacDonald <joe_macdonald@mentor.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "iSNS daemon and utility programs"
5DESCRIPTION = "This is a partial implementation of RFC4171, the Internet \
6Storage Name Service (iSNS). The distribution includes the iSNS server, \
7supporting persisten storage of registrations, isnsadm, a command line \
8utility for managing nodes, and isnsdd, a corresponding discovery daemon."
9HOMEPAGE = "http://github.com/gonzoleeman/open-isns/"
10LICENSE = "GPLv2+ & LGPLv2+"
11LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785"
12SECTION = "net"
13
14DEPENDS = "openssl"
15
16SRC_URI = "git://github.com/open-iscsi/open-isns"
17
18SRCREV = "cfdbcff867ee580a71bc9c18c3a38a6057df0150"
19
20S = "${WORKDIR}/git"
21
22inherit systemd autotools-brokensep update-rc.d
23
24EXTRA_OECONF = " --prefix=${prefix} --enable-shared"
25EXTRA_OEMAKE += "SYSTEMDDIR=${D}${systemd_unitdir}/system"
26
27do_install_append () {
28 oe_runmake INCDIR=${D}${includedir}/libisns/ install_hdrs
29 oe_runmake LIBDIR=${D}${libdir} install_lib
30
31 install -D -m 755 ${S}/etc/openisns.init ${D}${sysconfdir}/init.d/openisns
32 sed -i 's|daemon isnsd|start-stop-daemon --start --quiet --oknodo --exec ${sbindir}/isnsd --|' \
33 ${D}${sysconfdir}/init.d/openisns
34}
35
36FILES_${PN} += "${libdir} ${systemd_unitdir}"
37
38INITSCRIPT_NAME = "openisns"