blob: 74ae56c671e0b2a22426117e78e5fec4f429f85e [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Intel(R) Enclosure LED Utilities"
2
3DESCRIPTION = "The utilities are designed primarily to be used on storage servers \
4 utilizing MD devices (aka Linux Software RAID) for RAID arrays.\
5"
6HOMEPAGE = "https://github.com/intel/ledmon"
7
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
10"
11
12DEPENDS = "sg3-utils udev"
13
14inherit systemd
15
16SYSTEMD_SERVICE_${PN} = "ledmon.service"
17
18SRC_URI = "git://github.com/intel/ledmon;branch=master \
19 file://0002-include-sys-select.h-and-sys-types.h.patch \
20 "
21
22SRCREV = "ad1304ca1363d727425a1f23703c523e21feae4f"
23
24COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
25COMPATIBLE_HOST_libc-musl = "null"
26
27S = "${WORKDIR}/git"
28EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'"
29
30do_install_append() {
31 install -d ${D}/${systemd_unitdir}/system
32 oe_runmake DESTDIR=${D} install
33 oe_runmake DESTDIR=${D}${systemd_unitdir}/system install-systemd
34}