blob: f2891df50d3bf2a741339bdf3610339e12e06fc3 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "A GNU program for formatting C code"
2HOMEPAGE = "http://www.gnu.org/software/indent/"
3SECTION = "Applications/Text"
4DESCRIPTION = "Indent is a GNU program for beautifying C code, so that \
5it is easier to read. Indent can also convert from one C writing style \
6to a different one. Indent understands correct C syntax and tries to handle \
7incorrect C syntax. \
8Install the indent package if you are developing applications in C and \
9you want a program to format your code."
10LICENSE = "GPLv3"
11LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
12DEPENDS = "virtual/gettext"
13
14SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
15 file://0001-src-indent.c-correct-the-check-for-locale.h.patch \
16 file://0001-Makefile.am-remove-regression-dir.patch \
17"
18SRC_URI[md5sum] = "4764b6ac98f6654a35da117b8e5e8e14"
19SRC_URI[sha256sum] = "e77d68c0211515459b8812118d606812e300097cfac0b4e9fb3472664263bb8b"
20
21inherit autotools gettext
22
23CFLAGS_class-native += " -Wno-error=unused-value"
24
25FILES_${PN}-doc += "/usr/doc/indent/indent.html"
26
27BBCLASSEXTEND = "native"