blob: 4c1393c946ca2f6a7ea79c33e927066ae9dd8c79 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "A garbage collector for C and C++"
2
3DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\
4 used as a garbage collecting replacement for C malloc or C++ new. It allows\
5 you to allocate memory basically as you normally would, without explicitly\
6 deallocating memory that is no longer useful. The collector automatically\
7 recycles memory when it determines that it can no longer be otherwise\
8 accessed.\
9 The collector is also used by a number of programming language\
10 implementations that either use C as intermediate code, want to facilitate\
11 easier interoperation with C libraries, or just prefer the simple collector\
12 interface.\
13 Alternatively, the garbage collector may be used as a leak detector for C\
14 or C++ programs, though that is not its primary goal.\
15 Empirically, this collector works with most unmodified C programs, simply\
16 by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\
17 calls, and removing free calls."
18
19HOMEPAGE = "http://www.hboehm.info/gc/"
20SECTION = "devel"
21LICENSE = "MIT"
22LIC_FILES_CHKSUM = "file://README.QUICK;md5=81b447d779e278628c843aef92f088fa"
23
24SRCREV = "d3dede3ce4462cd82a15f161af797ca51654546a"
25SRC_URI = "git://github.com/ivmai/bdwgc.git;branch=release-8_0 \
26 "
27
28FILES_${PN}-doc = "${datadir}"
29
30S = "${WORKDIR}/git"
31
32ARM_INSTRUCTION_SET = "arm"
33
34inherit autotools pkgconfig
35
36# by default use external libatomic-ops
37PACKAGECONFIG ??= "libatomic-ops"
38PACKAGECONFIG[libatomic-ops] = "--with-libatomic-ops=yes,--with-libatomic-ops=no,libatomic-ops"
39
40BBCLASSEXTEND = "native nativesdk"