blob: 221022b7bcb25094d193f938061b5c2e8f73aa21 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001pkg_postinst_modules () {
2if [ -z "$D" ]; then
3 depmod -a ${KERNEL_VERSION}
4else
5 # image.bbclass will call depmodwrapper after everything is installed,
6 # no need to do it here as well
7 :
8fi
9}
10
11pkg_postrm_modules () {
12if [ -z "$D" ]; then
13 depmod -a ${KERNEL_VERSION}
14else
15 depmodwrapper -a -b $D ${KERNEL_VERSION}
16fi
17}
18
19autoload_postinst_fragment() {
20if [ x"$D" = "x" ]; then
21 modprobe %s || true
22fi
23}
24
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025PACKAGE_WRITE_DEPS += "kmod-native depmodwrapper-cross"
26
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027do_install_append() {
28 install -d ${D}${sysconfdir}/modules-load.d/ ${D}${sysconfdir}/modprobe.d/
29}
30
31PACKAGESPLITFUNCS_prepend = "split_kernel_module_packages "
32
Brad Bishop316dfdd2018-06-25 12:45:53 -040033KERNEL_MODULES_META_PACKAGE ?= "${@ d.getVar("KERNEL_PACKAGE_NAME") or "kernel" }-modules"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034
Patrick Williamsc0f7c042017-02-23 20:41:17 -060035KERNEL_MODULE_PACKAGE_PREFIX ?= ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -050036KERNEL_MODULE_PACKAGE_SUFFIX ?= "-${KERNEL_VERSION}"
37KERNEL_MODULE_PROVIDE_VIRTUAL ?= "1"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060038
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039python split_kernel_module_packages () {
40 import re
41
42 modinfoexp = re.compile("([^=]+)=(.*)")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050043
44 def extract_modinfo(file):
45 import tempfile, subprocess
Brad Bishop6e60e8b2018-02-01 10:27:11 -050046 tempfile.tempdir = d.getVar("WORKDIR")
Brad Bishopc342db32019-05-15 21:57:59 -040047 compressed = re.match( r'.*\.([xg])z$', file)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050048 tf = tempfile.mkstemp()
49 tmpfile = tf[1]
Brad Bishopc342db32019-05-15 21:57:59 -040050 if compressed:
51 tmpkofile = tmpfile + ".ko"
52 if compressed.group(1) == 'g':
53 cmd = "gunzip -dc %s > %s" % (file, tmpkofile)
54 subprocess.check_call(cmd, shell=True)
55 elif compressed.group(1) == 'x':
56 cmd = "xz -dc %s > %s" % (file, tmpkofile)
57 subprocess.check_call(cmd, shell=True)
58 else:
59 msg = "Cannot decompress '%s'" % file
60 raise msg
61 cmd = "%sobjcopy -j .modinfo -O binary %s %s" % (d.getVar("HOST_PREFIX") or "", tmpkofile, tmpfile)
62 else:
63 cmd = "%sobjcopy -j .modinfo -O binary %s %s" % (d.getVar("HOST_PREFIX") or "", file, tmpfile)
Brad Bishopd7bf8c12018-02-25 22:55:05 -050064 subprocess.check_call(cmd, shell=True)
Brad Bishop19323692019-04-05 15:28:33 -040065 # errors='replace': Some old kernel versions contain invalid utf-8 characters in mod descriptions (like 0xf6, 'รถ')
66 f = open(tmpfile, errors='replace')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050067 l = f.read().split("\000")
68 f.close()
69 os.close(tf[0])
70 os.unlink(tmpfile)
Brad Bishopc342db32019-05-15 21:57:59 -040071 if compressed:
72 os.unlink(tmpkofile)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050073 vals = {}
74 for i in l:
75 m = modinfoexp.match(i)
76 if not m:
77 continue
78 vals[m.group(1)] = m.group(2)
79 return vals
80
Patrick Williamsc124f4f2015-09-15 14:41:29 -050081 def frob_metadata(file, pkg, pattern, format, basename):
82 vals = extract_modinfo(file)
83
Brad Bishop6e60e8b2018-02-01 10:27:11 -050084 dvar = d.getVar('PKGD')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050085
86 # If autoloading is requested, output /etc/modules-load.d/<name>.conf and append
87 # appropriate modprobe commands to the postinst
Brad Bishop6e60e8b2018-02-01 10:27:11 -050088 autoloadlist = (d.getVar("KERNEL_MODULE_AUTOLOAD") or "").split()
89 autoload = d.getVar('module_autoload_%s' % basename)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050090 if autoload and autoload == basename:
91 bb.warn("module_autoload_%s was replaced by KERNEL_MODULE_AUTOLOAD for cases where basename == module name, please drop it" % basename)
92 if autoload and basename not in autoloadlist:
93 bb.warn("module_autoload_%s is defined but '%s' isn't included in KERNEL_MODULE_AUTOLOAD, please add it there" % (basename, basename))
94 if basename in autoloadlist:
95 name = '%s/etc/modules-load.d/%s.conf' % (dvar, basename)
96 f = open(name, 'w')
97 if autoload:
98 for m in autoload.split():
99 f.write('%s\n' % m)
100 else:
101 f.write('%s\n' % basename)
102 f.close()
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500103 postinst = d.getVar('pkg_postinst_%s' % pkg)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500104 if not postinst:
105 bb.fatal("pkg_postinst_%s not defined" % pkg)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500106 postinst += d.getVar('autoload_postinst_fragment') % (autoload or basename)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500107 d.setVar('pkg_postinst_%s' % pkg, postinst)
108
109 # Write out any modconf fragment
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500110 modconflist = (d.getVar("KERNEL_MODULE_PROBECONF") or "").split()
111 modconf = d.getVar('module_conf_%s' % basename)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500112 if modconf and basename in modconflist:
113 name = '%s/etc/modprobe.d/%s.conf' % (dvar, basename)
114 f = open(name, 'w')
115 f.write("%s\n" % modconf)
116 f.close()
117 elif modconf:
118 bb.error("Please ensure module %s is listed in KERNEL_MODULE_PROBECONF since module_conf_%s is set" % (basename, basename))
119
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500120 files = d.getVar('FILES_%s' % pkg)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500121 files = "%s /etc/modules-load.d/%s.conf /etc/modprobe.d/%s.conf" % (files, basename, basename)
122 d.setVar('FILES_%s' % pkg, files)
123
124 if "description" in vals:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500125 old_desc = d.getVar('DESCRIPTION_' + pkg) or ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500126 d.setVar('DESCRIPTION_' + pkg, old_desc + "; " + vals["description"])
127
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500128 rdepends = bb.utils.explode_dep_versions2(d.getVar('RDEPENDS_' + pkg) or "")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600129 modinfo_deps = []
130 if "depends" in vals and vals["depends"] != "":
131 for dep in vals["depends"].split(","):
132 on = legitimize_package_name(dep)
133 dependency_pkg = format % on
134 modinfo_deps.append(dependency_pkg)
135 for dep in modinfo_deps:
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500136 if not dep in rdepends:
137 rdepends[dep] = []
138 d.setVar('RDEPENDS_' + pkg, bb.utils.join_deps(rdepends, commasep=False))
139
140 # Avoid automatic -dev recommendations for modules ending with -dev.
141 d.setVarFlag('RRECOMMENDS_' + pkg, 'nodeprrecs', 1)
142
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500143 # Provide virtual package without postfix
144 providevirt = d.getVar('KERNEL_MODULE_PROVIDE_VIRTUAL')
145 if providevirt == "1":
146 postfix = format.split('%s')[1]
147 d.setVar('RPROVIDES_' + pkg, pkg.replace(postfix, ''))
148
Brad Bishop316dfdd2018-06-25 12:45:53 -0400149 kernel_package_name = d.getVar("KERNEL_PACKAGE_NAME") or "kernel"
150 kernel_version = d.getVar("KERNEL_VERSION")
151
Brad Bishopc342db32019-05-15 21:57:59 -0400152 module_regex = r'^(.*)\.k?o(?:\.[xg]z)?$'
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600153
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500154 module_pattern_prefix = d.getVar('KERNEL_MODULE_PACKAGE_PREFIX')
155 module_pattern_suffix = d.getVar('KERNEL_MODULE_PACKAGE_SUFFIX')
Brad Bishop316dfdd2018-06-25 12:45:53 -0400156 module_pattern = module_pattern_prefix + kernel_package_name + '-module-%s' + module_pattern_suffix
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500157
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500158 postinst = d.getVar('pkg_postinst_modules')
159 postrm = d.getVar('pkg_postrm_modules')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500160
Brad Bishop316dfdd2018-06-25 12:45:53 -0400161 modules = do_split_packages(d, root='${nonarch_base_libdir}/modules', file_regex=module_regex, output_pattern=module_pattern, description='%s kernel module', postinst=postinst, postrm=postrm, recursive=True, hook=frob_metadata, extra_depends='%s-%s' % (kernel_package_name, kernel_version))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500162 if modules:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500163 metapkg = d.getVar('KERNEL_MODULES_META_PACKAGE')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500164 d.appendVar('RDEPENDS_' + metapkg, ' '+' '.join(modules))
165
166 # If modules-load.d and modprobe.d are empty at this point, remove them to
167 # avoid warnings. removedirs only raises an OSError if an empty
168 # directory cannot be removed.
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500169 dvar = d.getVar('PKGD')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500170 for dir in ["%s/etc/modprobe.d" % (dvar), "%s/etc/modules-load.d" % (dvar), "%s/etc" % (dvar)]:
171 if len(os.listdir(dir)) == 0:
172 os.rmdir(dir)
173}
174
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500175do_package[vardeps] += '${@" ".join(map(lambda s: "module_conf_" + s, (d.getVar("KERNEL_MODULE_PROBECONF") or "").split()))}'