blob: 96beea53a73aa4738fb6a0221e7c6896a8b3cbc8 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Systemd system configuration"
2DESCRIPTION = "Systemd may require slightly different configuration for \
3different machines. For example, qemu machines require a longer \
4DefaultTimeoutStartSec setting."
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
8SRC_URI = "\
9 file://journald.conf \
10 file://logind.conf \
11 file://system.conf \
12 file://system.conf-qemuall \
13"
14
15do_install() {
16 install -D -m0644 ${WORKDIR}/journald.conf ${D}${systemd_unitdir}/journald.conf.d/00-${PN}.conf
17 install -D -m0644 ${WORKDIR}/logind.conf ${D}${systemd_unitdir}/logind.conf.d/00-${PN}.conf
18 install -D -m0644 ${WORKDIR}/system.conf ${D}${systemd_unitdir}/system.conf.d/00-${PN}.conf
19}
20
21# Based on change from YP bug 8141, OE commit 5196d7bacaef1076c361adaa2867be31759c1b52
22do_install_append_qemuall() {
23 install -D -m0644 ${WORKDIR}/system.conf-qemuall ${D}${systemd_unitdir}/system.conf.d/01-${PN}.conf
24}
25
26PACKAGE_ARCH = "${MACHINE_ARCH}"
27
28FILES_${PN} = "\
29 ${systemd_unitdir}/journald.conf.d/ \
30 ${systemd_unitdir}/logind.conf.d/ \
31 ${systemd_unitdir}/system.conf.d/ \
32"