blob: 4fdc7ee244f64b32cc6819d50193229b4a82b596 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "The PyPA recommended tool for installing Python packages"
2HOMEPAGE = "https://pypi.python.org/pypi/pip"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e"
6
7DEPENDS += "python3 python3-setuptools-native"
8
9SRC_URI[md5sum] = "1c5edb0924a0d7d79f3a2e3df05009b4"
10SRC_URI[sha256sum] = "6e6f197a1abfb45118dbb878b5c859a0edbdd33fd250100bc015b67fded4b9f2"
11
12inherit pypi distutils3
13
14do_install_append() {
15 # Install as pip3 and leave pip2 as default
16 rm ${D}/${bindir}/pip
17}
18
19RDEPENDS_${PN} = "\
20 python3-compile \
21 python3-io \
22 python3-html \
23 python3-json \
24 python3-netserver \
25 python3-setuptools \
26 python3-unixadmin \
27 python3-xmlrpc \
28"
29
30BBCLASSEXTEND = "native nativesdk"