blob: 65bd9ae4946d916115fd3caa4353e4d0693c950b [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "XFt: X FreeType libary"
2
3DESCRIPTION = "Xft was designed to provide good support for scalable \
4fonts, and to do so efficiently. Unlike the core fonts system, it \
5supports features such as anti-aliasing and sub-pixel rasterisation. \
6Perhaps more importantly, it gives applications full control over the \
7way glyphs are rendered, making fine typesetting and WYSIWIG display \
8possible. Finally, it allows applications to use fonts that are not \
9installed system-wide for displaying documents with embedded fonts. Xft \
10is not compatible with the core fonts system: usage of Xft requires \
11fairly extensive changes to toolkits (user-interface libraries)."
12
13require xorg-lib-common.inc
14
15LICENSE = "MIT"
16LIC_FILES_CHKSUM = "file://COPYING;md5=90b90b60eb30f65fc9c2673d7cf59e24"
17
18DEPENDS += "virtual/libx11 libxrender freetype fontconfig"
19PROVIDES = "xft"
20
21PE = "1"
22
23SRC_URI[md5sum] = "4a433c24627b4ff60a4dd403a0990796"
24SRC_URI[sha256sum] = "225c68e616dd29dbb27809e45e9eadf18e4d74c50be43020ef20015274529216"
25
26XORG_PN = "libXft"
27
28BBCLASSEXTEND = "native nativesdk"
29
30python () {
31 if d.getVar('DEBIAN_NAMES'):
32 d.setVar('PKG_${PN}', '${MLPREFIX}libxft2')
33}