blob: fb9a728e334272751539fefc84a2389269b50de5 [file] [log] [blame]
Ken Chen811e6b72018-01-30 09:51:50 +08001SUMMARY = "centriq2400 VR sensor Re-Probe"
2DESCRIPTION = "IR38163 work on DC on state, need re-probe for centriq2400 HW design"
3PR = "r0"
Brad Bishop9921ced2018-11-07 12:50:34 -08004LICENSE = "Apache-2.0"
Brad Bishopc3a3b642019-09-13 14:02:27 -04005LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Ken Chen811e6b72018-01-30 09:51:50 +08006
7inherit obmc-phosphor-systemd
Ken Chen811e6b72018-01-30 09:51:50 +08008
9PROVIDES += 'virtual/ir38163-workaround'
10RPROVIDES_${PN} += 'virtual-ir38163-workaround'
11
12IR_REMOVE = "ir-remove@.service"
13IR_ADD = "ir-add@.service"
14INSTIR_REMOVE = "ir-remove@{0}.service"
15INSTIR_ADD = "ir-add@{0}.service"
16TGTFMT_OFF = "obmc-chassis-poweroff@{0}.target"
17TGTFMT_ON = "obmc-chassis-poweron@{0}.target"
18FMT_REMOVE = "../${IR_REMOVE}:${TGTFMT_OFF}.wants/${INSTIR_REMOVE}"
19FMT_ADD = "../${IR_ADD}:${TGTFMT_ON}.requires/${INSTIR_ADD}"
20
21SYSTEMD_SERVICE_${PN} += "${IR_REMOVE}"
22SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_REMOVE', 'OBMC_CHASSIS_INSTANCES')}"
23SYSTEMD_SERVICE_${PN} += "${IR_ADD}"
24SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_ADD', 'OBMC_CHASSIS_INSTANCES')}"
25
26SRC_URI += "file://ir38163_workaround.sh"
27
28do_install() {
29 install -d ${D}${bindir}
30 install -m 0755 ${WORKDIR}/ir38163_workaround.sh ${D}${bindir}/ir38163_workaround.sh
31}