blob: 4344841b5466944d39c9cea1d8768a6dcfe1d644 [file] [log] [blame]
Andrew Geisslerc9f78652020-09-18 14:11:35 -05001SECTION = "console/network"
2SUMMARY = "dhcpcd - a DHCP client"
3DESCRIPTION = "dhcpcd runs on your machine and silently configures your \
4 computer to work on the attached networks without trouble \
5 and mostly without configuration."
6
7HOMEPAGE = "http://roy.marples.name/projects/dhcpcd/"
8
9LICENSE = "BSD-2-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=9674cc803c5d71306941e6e8b5c002f2"
11
12UPSTREAM_CHECK_URI = "https://roy.marples.name/downloads/dhcpcd/"
13
14SRC_URI = "https://roy.marples.name/downloads/${BPN}/${BPN}-${PV}.tar.xz \
15 file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch \
16 file://dhcpcd.service \
17 file://dhcpcd@.service \
18 "
19
20SRC_URI[sha256sum] = "fcb2d19672d445bbfd38678fdee4f556ef967a3ea6bd81092d10545df2cb9666"
21
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050022inherit pkgconfig autotools-brokensep systemd useradd
Andrew Geisslerc9f78652020-09-18 14:11:35 -050023
24SYSTEMD_SERVICE_${PN} = "dhcpcd.service"
25
26PACKAGECONFIG ?= "udev ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
27
28PACKAGECONFIG[udev] = "--with-udev,--without-udev,udev,udev"
29PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
30
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050031EXTRA_OECONF = "--enable-ipv4 \
32 --dbdir=${localstatedir}/lib/${BPN} \
33 --runstatedir=/run \
34 "
35
36USERADD_PACKAGES = "${PN}"
37USERADD_PARAM_${PN} = "--system -d ${localstatedir}/lib/${BPN} -M -s /bin/false -U dhcpcd"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050038
39do_install_append () {
40 # install systemd unit files
41 install -d ${D}${systemd_unitdir}/system
42 install -m 0644 ${WORKDIR}/dhcpcd*.service ${D}${systemd_unitdir}/system
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050043
44 chmod 700 ${D}${localstatedir}/lib/${BPN}
45 chown dhcpcd:dhcpcd ${D}${localstatedir}/lib/${BPN}
Andrew Geisslerc9f78652020-09-18 14:11:35 -050046}
47
48FILES_${PN}-dbg += "${libdir}/dhcpcd/dev/.debug"