blob: 2ea4b12758eca69eb42c9d6defe47a33220fe524 [file] [log] [blame]
Andrew Geisslerc9f78652020-09-18 14:11:35 -05001SUMMARY = "ISC Kea DHCP Server"
2DESCRIPTION = "Kea is the next generation of DHCP software developed by ISC. It supports both DHCPv4 and DHCPv6 protocols along with their extensions, e.g. prefix delegation and dynamic updates to DNS."
3HOMEPAGE = "http://kea.isc.org"
4SECTION = "connectivity"
5LICENSE = "MPL-2.0 & Apache-2.0"
6LIC_FILES_CHKSUM = "file://COPYING;md5=68d95543d2096459290a4e6b9ceccffa"
7
8DEPENDS = "boost log4cplus openssl"
9
10SRC_URI = "\
11 http://ftp.isc.org/isc/kea/${PV}/${BP}.tar.gz \
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050012 file://0001-keactrl.in-create-var-lib-kea-and-var-run-kea-folder.patch \
Andrew Geisslerc9f78652020-09-18 14:11:35 -050013 file://kea-dhcp4.service \
14 file://kea-dhcp6.service \
15 file://kea-dhcp-ddns.service \
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050016 file://fix-multilib-conflict.patch \
Andrew Geisslerc9f78652020-09-18 14:11:35 -050017"
18SRC_URI[sha256sum] = "4e121f0e58b175a827581c69cb1d60778647049fa47f142940dddc9ce58f3c82"
19
20inherit autotools systemd
21
22SYSTEMD_SERVICE_${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service"
23SYSTEMD_AUTO_ENABLE = "disable"
24
25DEBUG_OPTIMIZATION_remove_mips = " -Og"
26DEBUG_OPTIMIZATION_append_mips = " -O"
27BUILD_OPTIMIZATION_remove_mips = " -Og"
28BUILD_OPTIMIZATION_append_mips = " -O"
29
30DEBUG_OPTIMIZATION_remove_mipsel = " -Og"
31DEBUG_OPTIMIZATION_append_mipsel = " -O"
32BUILD_OPTIMIZATION_remove_mipsel = " -Og"
33BUILD_OPTIMIZATION_append_mipsel = " -O"
34
35EXTRA_OECONF = "--with-boost-libs=-lboost_system \
36 --with-log4cplus=${STAGING_DIR_TARGET}${prefix} \
37 --with-openssl=${STAGING_DIR_TARGET}${prefix}"
38
39do_configure_prepend() {
40 # replace abs_top_builddir to avoid introducing the build path
41 # don't expand the abs_top_builddir on the target as the abs_top_builddir is meanlingless on the target
42 find ${S} -type f -name *.sh.in | xargs sed -i "s:@abs_top_builddir@:@abs_top_builddir_placeholder@:g"
43 sed -i "s:@abs_top_srcdir@:@abs_top_srcdir_placeholder@:g" ${S}/src/bin/admin/kea-admin.in
44}
45
46do_install_append() {
47 install -d ${D}${systemd_system_unitdir}
48 install -m 0644 ${WORKDIR}/kea-dhcp*service ${D}${systemd_system_unitdir}
49 sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@BASE_BINDIR@,${base_bindir},g' \
50 -e 's,@LOCALSTATEDIR@,${localstatedir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' \
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050051 ${D}${systemd_system_unitdir}/kea-dhcp*service ${D}${sbindir}/keactrl
Andrew Geisslerc9f78652020-09-18 14:11:35 -050052}
53
54do_install_append() {
55 rm -rf "${D}${localstatedir}"
56}
57
58FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a ${libdir}/hooks/*.a"
59FILES_${PN} += "${libdir}/hooks/*.so"
60
61PARALLEL_MAKEINST = ""