blob: 50c85787cdf105caa885c7fbf67450a155ac66bd [file] [log] [blame]
Deepak Kodihallid7963ee2017-06-13 12:52:19 -05001SUMMARY = "Cereal - A C++11 library for serialization"
2DESCRIPTION = "Cereal is a header-only C++11 serialization library."
3HOMEPAGE = "https://github.com/USCiLab/cereal"
4PR = "r1"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e612690af2f575dfd02e2e91443cea23"
8
9SRC_URI += "git://github.com/USCiLab/cereal"
10SRCREV = "51cbda5f30e56c801c07fe3d3aba5d7fb9e6cca4"
Brad Bishopf7baa352018-04-11 14:01:17 -040011PV = "1.2.2+git${SRCPV}"
Deepak Kodihallid7963ee2017-06-13 12:52:19 -050012
13S = "${WORKDIR}/git"
14
Brad Bishopff8e1cf2018-04-11 11:45:25 -040015ALLOW_EMPTY_${PN} = "1"
Deepak Kodihallid7963ee2017-06-13 12:52:19 -050016
17do_install () {
18 install -d ${D}${includedir}/cereal
19 cp -r ${S}/include/cereal/* ${D}${includedir}/cereal/
20}