blob: defa11c92944568722cdcc62ad568651caf4726c [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "File system QA test suite"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=74274e8a218423e49eefdea80bc55038"
4
5SRCREV_FORMAT = "xfstests_unionmount"
6
7SRC_URI = "git://git.kernel.org/pub/scm/fs/xfs/xfstests-dev.git;branch=master;name=xfstests \
8 git://github.com/amir73il/unionmount-testsuite.git;branch=master;protocol=https;name=unionmount;destsuffix=unionmount-testsuite \
9 file://0001-Add-a-return-type-to-aio_rw.patch \
10 file://0002-Drop-detached_mounts_propagation-and-remove-sys-moun.patch \
11 "
12
Andrew Geisslerc5535c92023-01-27 16:10:19 -060013SRCREV_xfstests = "fbd489798b31e32f0eaefcd754326a06aa5b166f"
Andrew Geissler517393d2023-01-13 08:55:19 -060014SRCREV_unionmount = "e3825b16b46f4c4574a1a69909944c059835f914"
15
16S = "${WORKDIR}/git"
17
18inherit autotools-brokensep useradd
19
20DEPENDS += "xfsprogs acl"
21RDEPENDS:${PN} += "\
22 bash \
23 bc \
24 coreutils \
25 e2fsprogs \
26 e2fsprogs-tune2fs \
27 e2fsprogs-resize2fs \
28 libaio \
29 libcap-bin \
30 overlayfs-progs \
31 perl \
32 python3 \
33 python3-core \
34 xfsprogs \
35 acl \
36"
37
38USERADD_PACKAGES = "${PN}"
39# these users are necessary to run the tests
40USERADD_PARAM:${PN} = "-U -m fsgqa; -N 123456-fsgqa; -N fsgqa2"
41
42EXTRA_OECONF = "INSTALL_USER=root INSTALL_GROUP=root"
43
44TARGET_CC_ARCH:append:libc-musl = " -D_LARGEFILE64_SOURCE"
45# install-sh script in the project is outdated
46# we use the one from the latest libtool to solve installation issues
47# It looks like the upstream is not interested in having it fixed :(
48# https://www.spinics.net/lists/fstests/msg16981.html
49do_configure:prepend() {
50 cp ${STAGING_DIR_NATIVE}${datadir}/libtool/build-aux/install-sh ${B}
51}
52
53do_install:append() {
54 unionmount_target_dir=${D}/usr/xfstests/unionmount-testsuite
55 install -d ${D}/usr/xfstests/unionmount-testsuite/tests
56 install -D ${WORKDIR}/unionmount-testsuite/tests/* -t $unionmount_target_dir/tests
57 install ${WORKDIR}/unionmount-testsuite/*.py -t $unionmount_target_dir
58 install ${WORKDIR}/unionmount-testsuite/run -t $unionmount_target_dir
59 install ${WORKDIR}/unionmount-testsuite/README -t $unionmount_target_dir
60}
61
62FILES:${PN} += "\
63 /usr/xfstests \
64"