blob: 0d898be82e1894d896431f983afcf7dfa60e35d8 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
2HOMEPAGE = "https://tevent.samba.org"
3SECTION = "libs"
4LICENSE = "LGPL-3.0-or-later"
5
6DEPENDS += "libtalloc libtirpc"
7RDEPENDS:python3-tevent = "python3"
8
9export PYTHONHASHSEED="1"
10
11SRC_URI = "https://samba.org/ftp/tevent/tevent-${PV}.tar.gz \
12 file://0001-Add-configure-options-for-packages.patch \
13 file://0002-Fix-pyext_PATTERN-for-cross-compilation.patch \
14 "
15
16SRC_URI:append:libc-musl = " file://cmocka-fix-musl-libc-conflicting-types-error.patch"
17
18LIC_FILES_CHKSUM = "file://tevent.h;endline=26;md5=47386b7c539bf2706b7ce52dc9341681"
19
20SRC_URI[md5sum] = "9f413f3184f79a4deecd9444242a5dca"
21SRC_URI[sha256sum] = "b9437a917fa55344361beb64ec9e0042e99cae8879882a62dd38f6abe2371d0c"
22
Andrew Geisslerc5535c92023-01-27 16:10:19 -060023inherit pkgconfig ptest waf-samba
Andrew Geissler517393d2023-01-13 08:55:19 -060024
25PACKAGECONFIG ??= "\
26 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
27 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
28"
29PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
30PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
31PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
32PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
33PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
34PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
35
36SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'attr', '', 'file://avoid-attr-unless-wanted.patch', d)}"
37
38S = "${WORKDIR}/tevent-${PV}"
39
40#cross_compile cannot use preforked process, since fork process earlier than point subproces.popen
41#to cross Popen
42export WAF_NO_PREFORK="yes"
43
44EXTRA_OECONF += "--disable-rpath \
45 --disable-rpath-install \
46 --bundled-libraries=cmocka \
47 --builtin-libraries=replace \
48 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
49 --without-gettext \
50 "
51
Andrew Geisslerc5535c92023-01-27 16:10:19 -060052do_install:append() {
53 install -Dm 0755 ${B}/bin/test_tevent_trace ${D}${bindir}/test_tevent_trace
54 install -Dm 0755 ${B}/bin/test_tevent_tag ${D}${bindir}/test_tevent_tag
55 install -Dm 0755 ${B}/bin/replace_testsuite ${D}${bindir}/replace_testsuite
56}
57
Andrew Geissler517393d2023-01-13 08:55:19 -060058PACKAGES += "python3-tevent"
59
60RPROVIDES:${PN}-dbg += "python3-tevent-dbg"
61
62FILES:${PN} += "${libdir}/tevent/*"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060063FILES:${PN}-ptest += "${bindir}/replace_testsuite \
64 ${bindir}/test_tevent_tag \
65 ${bindir}/test_tevent_trace \
66 ${libdir}/libcmocka-tevent.so"
Andrew Geissler517393d2023-01-13 08:55:19 -060067FILES:python3-tevent = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
68
69INSANE_SKIP:${MLPREFIX}python3-tevent = "dev-so"