blob: caa1bb3396315a5767e017910eff5a3782d67817 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Unbound is a validating, recursive, and caching DNS resolver"
2DESCRIPTION = "Unbound's design is a set of modular components which incorporate \
3 features including enhanced security (DNSSEC) validation, Internet Protocol \
4 Version 6 (IPv6), and a client resolver library API as an integral part of the \
5 architecture"
6
7HOMEPAGE = "https://www.unbound.net/"
8SECTION = "net"
9LICENSE = "BSD-3-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=5308494bc0590c0cb036afd781d78f06"
11
12SRC_URI = "git://github.com/NLnetLabs/unbound.git;protocol=http;branch=master;protocol=https \
13 file://0001-contrib-add-yocto-compatible-init-script.patch \
14"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060015SRCREV = "90831af981221bbce1cd7b15055562336760e484"
Patrick Williams92b42cb2022-09-03 06:53:57 -050016
17inherit autotools pkgconfig systemd update-rc.d
18
19DEPENDS = "openssl libevent libtool-native bison-native expat"
20RDEPENDS:${PN} = "bash openssl-bin daemonize"
21
22S = "${WORKDIR}/git"
23
24EXTRA_OECONF = "--with-libexpat=${STAGING_EXECPREFIXDIR} \
25 --with-ssl=${STAGING_EXECPREFIXDIR} \
26 --enable-largefile"
27
28PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
29PACKAGECONFIG[dnscrypt] = "--enable-dnscrypt, --disable-dnscrypt, libsodium"
30PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
31
32do_install:append() {
33 install -d ${D}${systemd_unitdir}/system
34 install -m 0644 ${B}/contrib/unbound.service ${D}${systemd_unitdir}/system
35
36 install -d ${D}${sysconfdir}/init.d
37 install -m 0755 ${S}/contrib/unbound.init ${D}${sysconfdir}/init.d/unbound
38}
39
40SYSTEMD_SERVICE:${PN} = "${BPN}.service"
41
42INITSCRIPT_NAME = "unbound"
43INITSCRIPT_PARAMS = "defaults"