blob: 7af62b741870c34b2c53fd19ae34d411ed7360c9 [file] [log] [blame]
Andrew Geisslerc5535c92023-01-27 16:10:19 -06001SUMMARY = "D-Bus wrapper in C++ for dbus"
2HOMEPAGE = "https://dbus-cxx.github.io/"
3BUGTRACKER = "https://github.com/libsigcplusplus/libsigcplusplus/issues"
4SECTION = "base"
5LICENSE = "LGPL-3.0-or-later | BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://COPYING;md5=24594f493407a4cd401ce9794e0b9308"
7
8SRC_URI = "git://github.com/dbus-cxx/dbus-cxx.git;branch=master;protocol=https \
9 file://0001-Include-missing-cstdint.patch"
10SRCREV = "898f6ea8f7ffe454e81a9337002df555728d4199"
11
12DEPENDS = "\
13 dbus \
14 libsigc++-3 \
15"
16
17RDEPENDS:${PN} = "\
18 dbus \
19 libsigc++-3 \
20"
21
22S = "${WORKDIR}/git"
23
24inherit pkgconfig cmake
25
26OECMAKE_FIND_ROOT_PATH_MODE_PROGRAM = "BOTH"