blob: 1c2c6e21e08245528884e90af2ff0d29404ae401 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Userspace utilities for fs-verity"
2DESCRIPTION = "fs-verity is a Linux kernel feature that does transparent \
3on-demand integrity/authenticity verification of the contents of read-only \
4files, using a hidden Merkle tree (hash tree) associated with the file. The \
5mechanism is similar to dm-verity, but implemented at the file level rather \
6than at the block device level."
7HOMEPAGE = "https://www.kernel.org/doc/html/latest/filesystems/fsverity.html"
8SECTION = "console"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=bc974d217b525ea216a336adb73e1220"
11
12SRCREV = "20e87c13075a8e5660a8d69fd6c93d4f7c5f01a5"
13SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/ebiggers/fsverity-utils.git;branch=master"
14
15S = "${WORKDIR}/git"
16
17DEPENDS = "openssl"
18
Andrew Geisslerc5535c92023-01-27 16:10:19 -060019EXTRA_OEMAKE:append = " PREFIX=${prefix} LIBDIR=${libdir} USE_SHARED_LIB=1"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000020# We want to statically link the binary to libfsverity on native Windows
21EXTRA_OEMAKE:remove:mingw32:class-nativesdk = "USE_SHARED_LIB=1"
22EXTRA_OEMAKE:remove:mingw32:class-native = "USE_SHARED_LIB=1"
23
24do_install() {
25 oe_runmake install DESTDIR=${D}
26}
27
28PACKAGES =+ "libfsverity"
29FILES:libfsverity = "${libdir}/libfsverity*${SOLIBS}"
30
31BBCLASSEXTEND = "native nativesdk"