blob: 57ade6162b4d4a855afc281e862d2bad400a4eb9 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001SUMMARY = "ODBC driver for PostgreSQL"
2DESCRIPTION = "\
3 This package provides a driver that allows ODBC-enabled applications to \
4 access PostgreSQL databases. ODBC is an abstraction layer that allows \
5 applications written for that layer to access databases in a manner \
6 that is relatively independent of the particular database management \
7 system. \
8 . \
9 You need to install this package if you want to use an application that \
10 provides database access through ODBC and you want that application to \
11 access a PostgreSQL database. This package would need to be installed \
12 on the same machine as that client application; the PostgreSQL database \
13 server can be on a different machine and does not need any additional \
14 software to accept ODBC clients. \
15"
16SECTION = "libs"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060017HOMEPAGE = "https://odbc.postgresql.org/"
Patrick Williamsddad1a12017-02-23 20:36:32 -060018
Andrew Geissler87f5cff2022-09-30 13:13:31 -050019LICENSE = "LGPL-2.0-only"
20LIC_FILES_CHKSUM = "file://license.txt;md5=6db3822fc7512e83087ba798da013692"
21
22SRC_URI = "http://ftp.postgresql.org/pub/odbc/versions/src/${BPN}-${PV}.tar.gz \
23 file://psqlodbc-remove-some-checks-for-cross-compiling.patch \
24 file://psqlodbc-donot-use-the-hardcode-libdir.patch \
25 file://psqlodbc-fix-for-ptest-support.patch \
26 file://run-ptest \
27"
28
29SRC_URI[sha256sum] = "b39b7e5c41fd6475c551112fa724bf57c4a446175ec4188a90e2844cc1612585"
30
Patrick Williamsddad1a12017-02-23 20:36:32 -060031DEPENDS += "postgresql unixodbc"
32
33EXTRA_OECONF = "\
34 ac_cv_lib_ltdl_lt_dlopen=no \
35 ac_cv_lib_pq_PQconnectdb=yes \
36 --with-unixodbc=yes \
37 --with-libpq=${STAGING_LIBDIR}/.. \
38 --enable-pthreads \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050039 LIBS='-lpthread' \
Patrick Williamsddad1a12017-02-23 20:36:32 -060040"
41
42inherit autotools pkgconfig ptest
43
44do_compile_ptest() {
45 oe_runmake -C ${B}/test
46}
47
48do_install_ptest() {
49 install -d ${D}${PTEST_PATH}
50 cp -a --no-preserve=ownership ${B}/test/exe ${S}/test/expected ${D}${PTEST_PATH}
51 install -m 0755 ${B}/test/reset-db ${D}${PTEST_PATH}
52 install -m 0755 ${B}/test/runsuite ${D}${PTEST_PATH}
53 install -m 0755 ${S}/test/odbcini-gen.sh ${D}${PTEST_PATH}
54 install -m 0755 ${S}/test/sampletables.sql ${D}${PTEST_PATH}
55 sed -i -e 's|@LIBDIR@|${libdir}|' ${D}${PTEST_PATH}/odbcini-gen.sh
56}
57
Patrick Williams213cb262021-08-07 19:21:33 -050058FILES:${PN} += "${libdir}"
Patrick Williamsddad1a12017-02-23 20:36:32 -060059
60# The tests need a local PostgreSQL server running
Patrick Williams213cb262021-08-07 19:21:33 -050061RDEPENDS:${PN}-ptest = "postgresql"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050062