blob: 582c29379aff9774e4ea1c73d74be51a8a7f4818 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Xerces-c is a validating xml parser written in C++"
2DESCRIPTION = "Xerces-C++ makes it easy to give your application \
3 the ability to read and write XML data. \
4 A shared library is provided for parsing, generating, \
5 manipulating, and validating XML documents using \
6 the DOM, SAX, and SAX2 APIs."
7HOMEPAGE = "http://xerces.apache.org/xerces-c/"
8SECTION = "libs"
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012SRC_URI = "http://archive.apache.org/dist/xerces/c/3/sources/${BP}.tar.bz2"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060013SRC_URI[sha256sum] = "74aa626fc71e729ee227602870dd29a5a01cd8c9c1c7330837a51da2eb5722cc"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050014
15inherit autotools
16
17PACKAGECONFIG ??= "curl icu"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018PACKAGECONFIG[curl] = "--with-curl=${STAGING_DIR_TARGET}${prefix},--with-curl=no,curl"
19PACKAGECONFIG[icu] = "--with-icu=${STAGING_DIR_TARGET}${prefix},--with-icu=no,icu"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020
Patrick Williams213cb262021-08-07 19:21:33 -050021do_install:prepend () {
Andrew Geisslerc5535c92023-01-27 16:10:19 -060022 sed -i s:-L${STAGING_LIBDIR}::g ${B}/xerces-c.pc
Patrick Williamsb48b7b42016-08-17 15:04:38 -050023}
24
25PACKAGES = "libxerces-c \
Patrick Williamsddad1a12017-02-23 20:36:32 -060026 libxerces-c-dev \
27 xerces-c-samples \
Patrick Williamsddad1a12017-02-23 20:36:32 -060028 libxerces-c-staticdev \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029 ${PN}-dbg \
Patrick Williamsddad1a12017-02-23 20:36:32 -060030"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050031
Patrick Williams213cb262021-08-07 19:21:33 -050032RPROVIDES:${PN}-dbg += "libxerces-c-dbg xerces-c-samples-dbg"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033
Andrew Geisslerc5535c92023-01-27 16:10:19 -060034FILES:libxerces-c = "${libdir}/libxerces-c-3.2.so"
Patrick Williams213cb262021-08-07 19:21:33 -050035FILES:libxerces-c-dev = "${libdir}/lib*.la \
Patrick Williamsddad1a12017-02-23 20:36:32 -060036 ${libdir}/libxerces-c.so \
37 ${libdir}/pkgconfig/xerces-c.pc \
38 ${includedir}/xercesc \
39"
Patrick Williams213cb262021-08-07 19:21:33 -050040FILES:xerces-c-samples = "${bindir}/*"
41FILES:libxerces-c-staticdev = "${libdir}/lib*.a"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050042
43BBCLASSEXTEND = "native"