blob: 0a7ad33c644d962cb4a0c4cbd1bedcbb6c974f78 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "XML-RPC for C/C++ is programming libraries and related tools to help you \
2write an XML-RPC server or client in C or C++."
3
4HOMEPAGE = "http://xmlrpc-c.sourceforge.net/"
Andrew Geissler595f6302022-01-24 19:11:47 +00005LICENSE = "BSD-3-Clause & MIT"
Brad Bishop19323692019-04-05 15:28:33 -04006LIC_FILES_CHKSUM = "file://doc/COPYING;md5=aefbf81ba0750f02176b6f86752ea951"
7
Andrew Geissler595f6302022-01-24 19:11:47 +00008SRC_URI = "git://github.com/mirror/xmlrpc-c.git;branch=master;protocol=https \
Brad Bishop19323692019-04-05 15:28:33 -04009 file://0001-test-cpp-server_abyss-Fix-build-with-clang-libc.patch \
10 file://0002-fix-formatting-issues.patch \
11 "
Andrew Geisslerc5535c92023-01-27 16:10:19 -060012#Release 1.54.06
13SRCREV = "00870af80021aa0a66cc72c9aeb00587cbfde560"
Brad Bishop19323692019-04-05 15:28:33 -040014
15S = "${WORKDIR}/git/stable"
16
Brad Bishop19323692019-04-05 15:28:33 -040017inherit autotools-brokensep binconfig pkgconfig
18
19TARGET_CFLAGS += "-Wno-narrowing"
20
21EXTRA_OEMAKE += "CC_FOR_BUILD='${BUILD_CC}' \
22 LD_FOR_BUILD='${BUILD_LD}' \
23 CFLAGS_FOR_BUILD='${BUILD_CFLAGS}' \
24 LDFLAGS_FOR_BUILD='${BUILD_LDFLAGS}' \
25 "
26
27EXTRA_OECONF += "--disable-libwww-client --disable-wininet-client"
28
29PACKAGECONFIG ??= "curl cplusplus"
30
Andrew Geissler595f6302022-01-24 19:11:47 +000031PACKAGECONFIG[abyss] = "--enable-abyss-server --enable-abyss-threads --enable-abyss-openssl,--disable-abyss-server --disable-abyss-threads --disable-abyss-openssl,openssl"
32PACKAGECONFIG[cplusplus] = "--enable-cplusplus,--disable-cplusplus"
33PACKAGECONFIG[curl] = "--enable-curl-client,--disable-curl-client,curl"
Brad Bishop19323692019-04-05 15:28:33 -040034
35do_configure() {
Andrew Geissler595f6302022-01-24 19:11:47 +000036 gnu-configize --verbose --force ${S}
Brad Bishop19323692019-04-05 15:28:33 -040037 autoconf
38 oe_runconf
39 # license is incompatible with lib/util/getoptx.*
40 rm -fv ${S}/tools/turbocharger/mod_gzip.c
41}
42
43BBCLASSEXTEND = "native"
44
45CLEANBROKEN = "1"