blob: 8e906a4483f09a887488025a82e4b4009e875b7f [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "C++ client for Redis based on hiredis"
2HOMEPAGE = "https://github.com/sewenew/redis-plus-plus"
3SECTION = "libs"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
6
Andrew Geisslerc5535c92023-01-27 16:10:19 -06007SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https \
8 file://0001-include-cstdint.patch"
9SRCREV = "f3b19a8a1f609d1a1b79002802e5cf8c336dc262"
Andrew Geissler595f6302022-01-24 19:11:47 +000010
11S = "${WORKDIR}/git"
12
13inherit cmake
14
Andrew Geisslerc5535c92023-01-27 16:10:19 -060015EXTRA_OECMAKE += "-DREDIS_PLUS_PLUS_USE_TLS=ON"
16
17DEPENDS += "hiredis openssl"
Andrew Geissler595f6302022-01-24 19:11:47 +000018
19RDEPENDS:${PN} += "hiredis"
20
21FILES_SOLIBSDEV = ""
22FILES:${PN} += " ${libdir}/libredis++.so*"
23
24INSANE_SKIP:${PN} += "dev-so"