blob: 0340901c22b945d8c218bb30d06f771f55985451 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Utility for IPMI control"
2DESCRIPTION = "This package contains a utility for interfacing with devices that support \
3the Intelligent Platform Management Interface specification. IPMI is \
4an open standard for machine health, inventory, and remote power control. \
5\
6This utility can communicate with IPMI-enabled devices through either a \
7kernel driver such as OpenIPMI or over the RMCP LAN protocol defined in \
8the IPMI specification. IPMIv2 adds support for encrypted LAN \
9communications and remote Serial-over-LAN functionality. \
10\
11It provides commands for reading the Sensor Data Repository (SDR) and \
12displaying sensor values, displaying the contents of the System Event \
13Log (SEL), printing Field Replaceable Unit (FRU) information, reading and \
14setting LAN configuration, and chassis power control. \
15"
16
17HOMEPAGE = "http://ipmitool.sourceforge.net/"
18SECTION = "kernel/userland"
19
20LICENSE = "BSD-3-Clause"
21LIC_FILES_CHKSUM = "file://COPYING;md5=9aa91e13d644326bf281924212862184"
22
23DEPENDS = "openssl readline ncurses"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050024SRCREV = "19d78782d795d0cf4ceefe655f616210c9143e62"
25SRC_URI = "git://github.com/ipmitool/ipmitool;protocol=https;branch=master \
26 ${IANA_ENTERPRISE_NUMBERS} \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050027 file://0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028 "
Andrew Geissler87f5cff2022-09-30 13:13:31 -050029IANA_ENTERPRISE_NUMBERS ?= ""
30
31# Add these via bbappend if this database is needed by the system
Patrick Williams2390b1b2022-11-03 13:47:49 -050032#IANA_ENTERPRISE_NUMBERS = "http://www.iana.org/assignments/enterprise-numbers;name=iana-enterprise-numbers;downloadfilename=iana-enterprise-numbers"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050033#SRC_URI[iana-enterprise-numbers.sha256sum] = "cdd97fc08325667434b805eb589104ae63f7a9eb720ecea73cb55110b383934c"
34
35S = "${WORKDIR}/git"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050036
37inherit autotools
38
Andrew Geissler87f5cff2022-09-30 13:13:31 -050039do_install:append() {
40 if [ -e ${WORKDIR}/iana-enterprise-numbers ]; then
41 install -Dm 0755 ${WORKDIR}/iana-enterprise-numbers ${D}${datadir}/misc/enterprise-numbers
42 fi
43}
44
Andrew Geissler595f6302022-01-24 19:11:47 +000045PACKAGES =+ "${PN}-ipmievd"
46FILES:${PN}-ipmievd += "${sbindir}/ipmievd"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050047FILES:${PN} += "${datadir}/misc"
Andrew Geissler595f6302022-01-24 19:11:47 +000048
Brad Bishop6e60e8b2018-02-01 10:27:11 -050049# --disable-dependency-tracking speeds up the build
50# --enable-file-security adds some security checks
51# --disable-intf-free disables FreeIPMI support - we don't want to depend on
52# FreeIPMI libraries, FreeIPMI has its own ipmitoool-like utility.
53#
54EXTRA_OECONF = "--disable-dependency-tracking --enable-file-security --disable-intf-free"