blob: 73620f37a644a1d5a6bde1c449ce3c4b9d44dc8b [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001# Copyright (C) 2022 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Library to parse raw trace event formats "
5HOMEPAGE = "https://git.kernel.org/pub/scm/libs/libtrace/libtraceevent.git/"
6LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
7LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=e6a75371ba4d16749254a51215d13f97 \
8 file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd"
9SECTION = "libs"
10DEPENDS = "libtraceevent bison-native flex-native"
11
Andrew Geisslerc5535c92023-01-27 16:10:19 -060012SRCREV = "af49d832f46631597e0aabb2302bd0f56a9cad29"
Andrew Geissler517393d2023-01-13 08:55:19 -060013SRC_URI = "git://git.kernel.org/pub/scm/libs/libtrace/libtracefs.git;branch=${BPN};protocol=https \
14 file://0001-makefile-Do-not-preserve-ownership-in-cp-command.patch \
15 "
16S = "${WORKDIR}/git"
17
18inherit pkgconfig
19
20do_install() {
21 oe_runmake install DESTDIR=${D} pkgconfig_dir=${libdir}/pkgconfig
22}