blob: d281bfde625c3fa4f2ec6dfb01ca46e56737879c [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "An HTTP and WebDAV client library with a C interface"
2HOMEPAGE = "http://www.webdav.org/neon/"
3SECTION = "libs"
4LICENSE = "LGPL-2.0-or-later"
5LIC_FILES_CHKSUM = "file://src/COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a \
6 file://src/ne_utils.h;beginline=1;endline=20;md5=34c8e338bfa0237561e68d30c3c71133"
7
8SRC_URI = "${DEBIAN_MIRROR}/main/n/neon27/neon27_${PV}.orig.tar.gz \
9 file://pkgconfig.patch \
10 file://0001-Disable-installing-documentation.patch \
11 file://run-ptest \
12 "
13
Andrew Geissler87f5cff2022-09-30 13:13:31 -050014SRC_URI[sha256sum] = "1bcdaabb63206b5e00c9a8c4b3672168b523b49eb559c5a486e3256463af34fd"
Patrick Williams92b42cb2022-09-03 06:53:57 -050015
16inherit autotools-brokensep binconfig-disabled lib_package pkgconfig ptest
17
18# Enable gnutls or openssl, not both
19PACKAGECONFIG ?= "expat gnutls libproxy webdav zlib nls"
20PACKAGECONFIG:class-native = "expat gnutls webdav zlib nls"
21PACKAGECONFIG:remove:libc-musl = "nls"
22
23PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat"
24PACKAGECONFIG[gnutls] = "--with-ssl=gnutls,,gnutls"
25PACKAGECONFIG[gssapi] = "--with-gssapi,--without-gssapi,krb5"
26PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy"
27PACKAGECONFIG[libxml2] = "--with-libxml2,--without-libxml2,libxml2"
28PACKAGECONFIG[nls] = ",--disable-nls,gettext-native"
29PACKAGECONFIG[openssl] = "--with-ssl=openssl,,openssl"
30PACKAGECONFIG[webdav] = "--enable-webdav,--disable-webdav,"
31PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
32
33EXTRA_OECONF += "--enable-shared --enable-threadsafe-ssl=posix"
34
35# Do not install into /usr/local
Andrew Geisslerc5535c92023-01-27 16:10:19 -060036EXTRA_OEMAKE:append:class-native = " prefix=${prefix_native}"
Patrick Williams92b42cb2022-09-03 06:53:57 -050037
38do_configure:prepend() {
39 echo "${PV}" > ${S}/.version
40}
41
42do_compile:append() {
43 if ${@bb.utils.contains('PACKAGECONFIG', 'nls', 'true', 'false', d)}; then
44 oe_runmake compile-gmo
45 fi
46 oe_runmake -C test
47}
48
49do_install_ptest(){
50 BASIC_TESTS="auth basic redirect request session socket string-tests \
51 stubs uri-tests util-tests"
52 DAV_TESTS="acl3744 lock oldacl props xml xmlreq"
53 mkdir "${D}${PTEST_PATH}/test"
54 for i in ${BASIC_TESTS} ${DAV_TESTS}
55 do
56 install -m 0755 "${B}/test/${i}" \
57 "${D}${PTEST_PATH}/test"
58 done
59}
60
61BINCONFIG = "${bindir}/neon-config"
62
63BBCLASSEXTEND = "native"