blob: b0f147c798d02f647f5e149ac7eebb1e5f9e2f65 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Smart card library and applications"
2DESCRIPTION = "OpenSC is a tool for accessing smart card devices. Basic\
3functionality (e.g. SELECT FILE, READ BINARY) should work on any ISO\
47816-4 compatible smart card. Encryption and decryption using private\
5keys on the smart card is possible with PKCS\
6such as the FINEID (Finnish Electronic IDentity) card. Swedish Posten\
7eID cards have also been confirmed to work."
8
Andrew Geisslerc5535c92023-01-27 16:10:19 -06009HOMEPAGE = "https://github.com/OpenSC/OpenSC/wiki"
Andrew Geissler517393d2023-01-13 08:55:19 -060010SECTION = "System Environment/Libraries"
11LICENSE = "LGPL-2.0-or-later"
12LIC_FILES_CHKSUM = "file://COPYING;md5=cb8aedd3bced19bd8026d96a8b6876d7"
13
14#v0.21.0
15SRCREV = "5497519ea6b4af596628f8f8f2f904bacaa3148f"
16SRC_URI = "git://github.com/OpenSC/OpenSC;branch=master;protocol=https \
17 "
18DEPENDS = "virtual/libiconv openssl"
19
20S = "${WORKDIR}/git"
21inherit autotools pkgconfig bash-completion
22
23EXTRA_OECONF = " \
24 --disable-static \
25 --disable-ctapi \
26 --disable-doc \
27 --disable-strict \
28"
29EXTRA_OEMAKE = "DESTDIR=${D}"
30
31PACKAGECONFIG ??= "pcsc"
32
33PACKAGECONFIG[openct] = "--enable-openct,--disable-openct,openct"
34PACKAGECONFIG[pcsc] = "--enable-pcsc,--disable-pcsc,pcsc-lite,pcsc-lite pcsc-lite-lib"
35
36RDEPENDS:${PN} = "readline"
37
38FILES:${PN} += "\
39 ${libdir}/opensc-pkcs11.so \
40 ${libdir}/onepin-opensc-pkcs11.so \
41 ${libdir}/pkcs11-spy.so \
42"
43FILES:${PN}-dev += "\
44 ${libdir}/pkcs11/opensc-pkcs11.so \
45 ${libdir}/pkcs11/onepin-opensc-pkcs11.so \
46 ${libdir}/pkcs11/pkcs11-spy.so \
47"
48
49BBCLASSEXTEND = "native"