blob: bf9de31f844e766474ce8ac415b8b2870e98351f [file] [log] [blame]
Brad Bishop0f291cc2019-09-01 15:16:57 -04001SUMMARY = "Intel RSTe with Linux OS SSI API Library"
2
3DESCRIPTION = "Intel Rapid Storage Technology enterprise with Linux OS* Standard Storage Interface API Library. \
4The library allows user to manage storage devices including creating and managing Raid arrays on systems with Intel chipset."
5
6HOMEPAGE = "http://irstessi.sourceforge.net/"
7
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://COPYING;md5=9d701a2fbb56039fd64afb2262008ddb"
10
11DEPENDS += "sg3-utils"
12
13SRC_URI = "http://sourceforge.net/projects/irstessi/files/${BPN}.${PV}.tgz \
14 file://0001-log-Avoid-shadowing-functions-from-std-lib.patch \
15 file://0002-boost-Backport-clang-support.patch \
16 file://0003-engine-Define-discover-const-String-path-in-base-cla.patch \
17 file://0004-Do-not-override-flags-coming-from-build-environment.patch \
18 file://0005-enable-out-of-source-tree-builds.patch \
19 file://0001-Don-t-use-__GNUC_PREREQ.patch \
20 file://0002-Use-stangard-int-types.patch \
21 file://0003-replace-canonicalize_file_name-with-realpath.patch \
22 file://0004-include-limits.h.patch \
23 file://0001-Include-libgen.h.patch \
24 "
25SRC_URI[md5sum] = "d06c9b426437a7697d77266e9835b520"
26SRC_URI[sha256sum] = "59daab29363d6e9f07c524029c4239653cfbbee6b0e57fd75df62499728dad8a"
27
28S ="${WORKDIR}/${BPN}.${PV}"
29
30inherit autotools
31
Andrew Geisslerc5535c92023-01-27 16:10:19 -060032CXXFLAGS += "-std=gnu++14"
33
Patrick Williams213cb262021-08-07 19:21:33 -050034do_configure:prepend(){
Brad Bishop0f291cc2019-09-01 15:16:57 -040035 ${S}/autogen.sh
36}
37
Patrick Williams213cb262021-08-07 19:21:33 -050038RDEPENDS:${PN} += "mdadm"
Brad Bishop0e2770c2020-01-21 07:31:46 -050039
Patrick Williams213cb262021-08-07 19:21:33 -050040COMPATIBLE_HOST:powerpc = 'null'
41COMPATIBLE_HOST:powerpc64le = 'null'