blob: f184b89e59ce75ed3645403d00cc7a8beaa2d634 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Perl interface to the libxml2 library"
2DESCRIPTION = "This module is an interface to libxml2, providing XML and HTML parsers \
3with DOM, SAX and XMLReader interfaces, a large subset of DOM Layer 3 \
4interface and a XML::XPath-like interface to XPath API of libxml2. \
5The module is split into several packages which are not described in this \
6section; unless stated otherwise, you only need to use XML::LibXML; in \
7your programs."
8
9HOMEPAGE = "http://search.cpan.org/dist/XML-LibXML-1.99/"
10SECTION = "libs"
Patrick Williams92b42cb2022-09-03 06:53:57 -050011LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Brad Bishop19323692019-04-05 15:28:33 -040012DEPENDS += "libxml2 \
13 libxml-sax-perl-native \
14 zlib \
15"
Patrick Williams213cb262021-08-07 19:21:33 -050016RDEPENDS:${PN} += "\
Brad Bishop19323692019-04-05 15:28:33 -040017 libxml2 \
18 libxml-sax-perl \
19 libxml-sax-base-perl \
20 perl-module-encode \
21 perl-module-data-dumper \
22 zlib \
23"
24
25SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/XML-LibXML-${PV}.tar.gz;name=libxml \
26 file://disable-libxml2-check.patch \
27 file://fix-CATALOG-conditional-compile.patch \
28 file://using-DOCB-conditional.patch \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060029 file://0001-libxml-mm-Fix-function-prototypes-in-function-pointe.patch \
Brad Bishop19323692019-04-05 15:28:33 -040030"
31LIC_FILES_CHKSUM = "file://debian/copyright;md5=64eda1bc135f0ece1d1187f2a8ac82c1 \
32 file://LICENSE;md5=97871bde150daeb5e61ad95137ff2446 \
33"
34SRC_URI[libxml.md5sum] = "dce687dd8b7e82d1c359fd74b1852f64"
35SRC_URI[libxml.sha256sum] = "f0bca4d0c2da35d879fee4cd13f352014186cedab27ab5e191f39b5d7d4f46cf"
36
37S = "${WORKDIR}/XML-LibXML-${PV}"
38
Brad Bishop15ae2502019-06-18 21:44:24 -040039inherit cpan ptest-perl
Brad Bishop19323692019-04-05 15:28:33 -040040
41EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR}/libxml2 LIBS=-L${STAGING_LIBDIR}"
42
43BBCLASSEXTEND = "native"
44
45CFLAGS += " -D_GNU_SOURCE "
46BUILD_CFLAGS += " -D_GNU_SOURCE "
47
Patrick Williams213cb262021-08-07 19:21:33 -050048FILES:${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/XML/LibXML/.debug/"
Brad Bishop15ae2502019-06-18 21:44:24 -040049
Patrick Williams213cb262021-08-07 19:21:33 -050050RDEPENDS:${PN}-ptest += " \
Brad Bishop15ae2502019-06-18 21:44:24 -040051 liburi-perl \
52 perl-module-encode-byte \
53 perl-module-encode-unicode \
54 perl-module-locale \
55 perl-module-perlio-scalar \
56 perl-module-test-more \
57"
58
Patrick Williams213cb262021-08-07 19:21:33 -050059do_install:prepend() {
Brad Bishop15ae2502019-06-18 21:44:24 -040060 # test requires "-T" (taint) command line option
61 rm -rf ${B}/t/pod.t
62 # this only applies to author build
63 rm -rf ${B}/t/pod-files-presence.t
64}
65
66do_install_ptest() {
67 cp -r ${B}/t/data ${D}${PTEST_PATH}/t/
68 cp -r ${B}/t/lib ${D}${PTEST_PATH}/t/
69 cp -r ${B}/example ${D}${PTEST_PATH}
70 cp -r ${B}/test ${D}${PTEST_PATH}
71 chown -R root:root ${D}${PTEST_PATH}
72}