blob: a1659c5f628eedec5a8761d71f026c8bf2589229 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7# Common infrastructure for Python packages that use PEP-517 compliant packaging.
8# https://www.python.org/dev/peps/pep-0517/
9#
10# This class will build a wheel in do_compile, and use pypa/installer to install
11# it in do_install.
12
Andrew Geisslerc5535c92023-01-27 16:10:19 -060013DEPENDS:append = " python3-build-native python3-installer-native"
Patrick Williams92b42cb2022-09-03 06:53:57 -050014
15# Where to execute the build process from
16PEP517_SOURCE_PATH ?= "${S}"
17
18# The directory where wheels will be written
19PEP517_WHEEL_PATH ?= "${WORKDIR}/dist"
20
Andrew Geisslerc5535c92023-01-27 16:10:19 -060021# Other options to pass to build
22PEP517_BUILD_OPTS ?= ""
Patrick Williams92b42cb2022-09-03 06:53:57 -050023
24# The interpreter to use for installed scripts
25PEP517_INSTALL_PYTHON = "python3"
26PEP517_INSTALL_PYTHON:class-native = "nativepython3"
27
28# pypa/installer option to control the bytecode compilation
29INSTALL_WHEEL_COMPILE_BYTECODE ?= "--compile-bytecode=0"
30
31# PEP517 doesn't have a specific configure step, so set an empty do_configure to avoid
32# running base_do_configure.
33python_pep517_do_configure () {
34 :
35}
36
37# When we have Python 3.11 we can parse pyproject.toml to determine the build
38# API entry point directly
39python_pep517_do_compile () {
Andrew Geisslerc5535c92023-01-27 16:10:19 -060040 nativepython3 -m build --no-isolation --wheel --outdir ${PEP517_WHEEL_PATH} ${PEP517_SOURCE_PATH} ${PEP517_BUILD_OPTS}
Patrick Williams92b42cb2022-09-03 06:53:57 -050041}
42do_compile[cleandirs] += "${PEP517_WHEEL_PATH}"
43
44python_pep517_do_install () {
45 COUNT=$(find ${PEP517_WHEEL_PATH} -name '*.whl' | wc -l)
46 if test $COUNT -eq 0; then
47 bbfatal No wheels found in ${PEP517_WHEEL_PATH}
48 elif test $COUNT -gt 1; then
49 bbfatal More than one wheel found in ${PEP517_WHEEL_PATH}, this should not happen
50 fi
51
52 nativepython3 -m installer ${INSTALL_WHEEL_COMPILE_BYTECODE} --interpreter "${USRBINPATH}/env ${PEP517_INSTALL_PYTHON}" --destdir=${D} ${PEP517_WHEEL_PATH}/*.whl
53}
54
55# A manual do_install that just uses unzip for bootstrapping purposes. Callers should DEPEND on unzip-native.
56python_pep517_do_bootstrap_install () {
57 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
58 unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ${PEP517_WHEEL_PATH}/*.whl
59}
60
61EXPORT_FUNCTIONS do_configure do_compile do_install