blob: 2e5b1e80695ce61417f7137c26e2bbca83f42c3a [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "This provides a PEP 517 build backend for packages using Flit."
2DESCRIPTION = "This provides a PEP 517 build backend for packages using \
3Flit. The only public interface is the API specified by PEP 517, at \
4flit_core.buildapi."
5HOMEPAGE = "https://github.com/pypa/flit"
6BUGTRACKER = "https://github.com/pypa/flit/issues"
7
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=41eb78fa8a872983a882c694a8305f08"
10
Patrick Williams7784c422022-11-17 07:29:11 -060011SRC_URI[sha256sum] = "d0f2a8f4bd45dc794befbf5839ecc0fd3830d65a57bd52b5997542fac5d5e937"
Andrew Geissler9aee5002022-03-30 16:27:02 +000012
13inherit pypi python_flit_core
14
15# Need to install by hand as there's a dependency loop
Andrew Geisslerc5535c92023-01-27 16:10:19 -060016DEPENDS:remove:class-native = " python3-build-native python3-installer-native"
Andrew Geissler9aee5002022-03-30 16:27:02 +000017DEPENDS:append:class-native = " unzip-native"
18
19# We need the full flit tarball
20PYPI_PACKAGE = "flit"
21PEP517_SOURCE_PATH = "${S}/flit_core"
22
Andrew Geissler615f2f12022-07-15 14:00:58 -050023do_compile:class-native () {
24 python_flit_core_do_manual_build
25}
26
Andrew Geissler9aee5002022-03-30 16:27:02 +000027do_install:class-native () {
28 python_pep517_do_bootstrap_install
29}
30
31PACKAGES =+ "${PN}-tests"
32
33FILES:${PN}-tests += "\
34 ${PYTHON_SITEPACKAGES_DIR}/flit_core/tests/* \
35"
36
37BBCLASSEXTEND = "native nativesdk"