blob: 7b69c880c14584e052f404cc41f37a7edce3db81 [file] [log] [blame]
Andrew Geisslerc5535c92023-01-27 16:10:19 -06001DESCRIPTION = "Core utilities for Python packages"
2HOMEPAGE = "https://github.com/pypa/packaging"
3LICENSE = "Apache-2.0 | BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91"
5
6SRC_URI[sha256sum] = "b6ad297f8907de0fa2fe1ccbd26fdaf387f5f47c7275fedf8cce89f99446cf97"
7
8inherit pypi python_flit_core
9
10BBCLASSEXTEND = "native nativesdk"
11
12# Bootstrap the native build
13DEPENDS:remove:class-native = "python3-build-native"
14
15do_compile:class-native () {
16 python_flit_core_do_manual_build
17}