blob: 2b9bbe69dbb0b0a490713eab7421f685b481736b [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Display or change ethernet card settings"
2DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
3HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
4SECTION = "console/network"
5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
8
9SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
10 file://run-ptest \
11 file://avoid_parallel_tests.patch \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060012 file://0001-marvell.c-define-_GNU_SOURCE.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050013 "
14
Andrew Geisslerc5535c92023-01-27 16:10:19 -060015SRC_URI[sha256sum] = "1d03f1ce324fbd95591191c42ac0c4c9cc721e067b929083a20a46c4b4731436"
Patrick Williams92b42cb2022-09-03 06:53:57 -050016
17UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/"
18
19inherit autotools ptest bash-completion pkgconfig
20
21RDEPENDS:${PN}-ptest += "make"
22
23PACKAGECONFIG ?= "netlink"
24PACKAGECONFIG[netlink] = "--enable-netlink,--disable-netlink,libmnl,"
25
26do_compile_ptest() {
27 oe_runmake buildtest-TESTS
28}
29
30do_install_ptest () {
31 cp ${B}/Makefile ${D}${PTEST_PATH}
32 install ${B}/test-cmdline ${D}${PTEST_PATH}
33 if ${@bb.utils.contains('PACKAGECONFIG', 'netlink', 'false', 'true', d)}; then
34 install ${B}/test-features ${D}${PTEST_PATH}
35 fi
36 install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
37 sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
38}