blob: 1fce127d07bf964c5eecc84b83e6d48d8ef6223a [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Text shaping library"
2DESCRIPTION = "HarfBuzz is an OpenType text shaping engine."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz"
4BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://COPYING;md5=6ee0f16281694fb6aa689cca1e0fb3da \
8 file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc \
9 "
10
Andrew Geisslerc5535c92023-01-27 16:10:19 -060011SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/${BPN}-${PV}.tar.xz \
12 file://0001-test-threads-hb-subset-threads.cc-add-missing-cstdio.patch"
Andrew Geissler517393d2023-01-13 08:55:19 -060013SRC_URI[sha256sum] = "1d1010a1751d076d5291e433c138502a794d679a7498d1268ee21e2d4a140eb4"
14
15inherit meson pkgconfig lib_package gtk-doc gobject-introspection github-releases
16
17GIR_MESON_ENABLE_FLAG = 'enabled'
18GIR_MESON_DISABLE_FLAG = 'disabled'
19GTKDOC_MESON_ENABLE_FLAG = 'enabled'
20GTKDOC_MESON_DISABLE_FLAG = 'disabled'
21
22PACKAGECONFIG ??= "cairo freetype glib icu"
23PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo"
24PACKAGECONFIG[freetype] = "-Dfreetype=enabled,-Dfreetype=disabled,freetype"
25PACKAGECONFIG[glib] = "-Dglib=enabled,-Dglib=disabled,glib-2.0"
26PACKAGECONFIG[graphite] = "-Dgraphite=enabled,-Dgraphite=disabled,graphite2"
27PACKAGECONFIG[icu] = "-Dicu=enabled,-Dicu=disabled,icu"
28
29PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset"
30
31LEAD_SONAME = "libharfbuzz.so"
32
33do_install:append() {
34 # If no tools are installed due to PACKAGECONFIG then this directory might
35 # still be installed, so remove it to stop packaging warnings.
36 [ ! -d ${D}${bindir} ] || rmdir --ignore-fail-on-non-empty ${D}${bindir}
37}
38
39FILES:${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"
40FILES:${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \
41 ${libdir}/libharfbuzz-icu.so \
42 ${libdir}/pkgconfig/harfbuzz-icu.pc \
43"
44FILES:${PN}-subset = "${libdir}/libharfbuzz-subset.so.*"
45
46BBCLASSEXTEND = "native nativesdk"